Skip to:
Content

BuddyPress.org

Opened 8 days ago

Last modified 7 days ago

#8169 reopened defect (bug)

Password Reset issue

Reported by: sdose Owned by:
Milestone: Awaiting Contributions Priority: highest
Severity: critical Version: 5.0.0
Component: Core Keywords: reporter-feedback close needs-testing
Cc:

Description

We have facing problem in regard to not able to reset password on both our websites keertionline.com & jylek.com

On clicking forgot password link in login form of keertionline.com:

Link received in email for resetting password, however on clicking the link, it is redirected page where it is again asking email ID to be provided instead of asking for providing new password. After providing email ID, we get message that "There is no account with that user name or email address".
If we provide User ID for forget password screen and on clicking link in email, we get screen for entering User ID and later after providing User ID, we get message that "Password reset not allowed for this user".

Hence unable to reset password for keertionline.com

Please refer to link below for screenshots.
Received Email Link: http://prntscr.com/q2rfjc
After click on link in email : https://prnt.sc/q2rek1
After entering username : https://prnt.sc/q2rek1

On clicking forgot password link in login form of jylek.com:

On clicking forgot password, we enter Email ID and we get a link in email for resetting password, however we are again asked to enter email ID and 2nd time email is recd with another password reset link. This password reset link is now asking for new password. Hence we need to repeat the cycle of receiving email for password reset.
Grateful, if you can help in providing a resolution to this critical issue on urgent basis.

Attachments (1)

8169.png (228.9 KB) - added by imath 7 days ago.

Download all attachments as: .zip

Change History (8)

#1 follow-up: @imath
8 days ago

  • Keywords reporter-feedback added

Hi,

Thanks for reporting this issue, I’ve noticed you are using a specific plugin to replace the wp-login.php page with a « mysecretlogin » page. I believe there’s a chance this might create an interference with BuddyPress.

  1. could you inform us what is the name/link on WordPress.org plugin’s directory of this plugin ?
  2. have you tried to deactivate this plugin to see if this was fixing the issue ?

#2 @imath
7 days ago

  • Milestone changed from 5.1.0 to Awaiting Review

This is not specific to 5.0.0 development cycle, and I believe it's not a BuddyPress issue as I wasn't able to reproduce using WordPress latest, BuddyPress latest (without any other plugins).

@imath
7 days ago

#3 @imath
7 days ago

  • Keywords close added; needs-testing removed
  • Priority changed from highest to normal
  • Severity changed from major to normal

Above is what I get when I reset my password. There is no issue with BuddyPress. Unless you provide us with more inputs such as the plugin name that is hiding you wp-login.php page, I suggest to close this ticket as worksforme

#4 in reply to: ↑ 1 @sdose
7 days ago

  • Keywords needs-testing added
  • Milestone Awaiting Review deleted
  • Priority changed from normal to highest
  • Resolution set to wontfix
  • Severity changed from normal to critical
  • Status changed from assigned to closed
  • Version set to 5.0.0
  1. could you inform us what is the name/link on WordPress.org plugin’s directory of this plugin ? :

Webcraftic Hide login page

  1. have you tried to deactivate this plugin to see if this was fixing the issue ?

Yes but still issue not solved.

please check on my website https://keertionline.com/

Replying to imath:

Hi,

Thanks for reporting this issue, I’ve noticed you are using a specific plugin to replace the wp-login.php page with a « mysecretlogin » page. I believe there’s a chance this might create an interference with BuddyPress.

  1. could you inform us what is the name/link on WordPress.org plugin’s directory of this plugin ?
  2. have you tried to deactivate this plugin to see if this was fixing the issue ?
Last edited 7 days ago by sdose (previous) (diff)

#5 follow-up: @imath
7 days ago

My tests showed it wasn’t involving BuddyPress, I advise you to deactivate all plugins (except BuddyPress) and use a Twentytheme to find which plugin/theme is conflicting by reactivating them one by one.

#6 in reply to: ↑ 5 @sdose
7 days ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Hi,

i can't deactivate the theme, because buddypress is already integrated with wplms. If WPLMS theme is deactivated, then i cannot check the process of login,registration, forgot password. Already Deactivate all plugin, except buddypress , still issue not solved.

Replying to imath:

My tests showed it wasn’t involving BuddyPress, I advise you to deactivate all plugins (except BuddyPress) and use a Twentytheme to find which plugin/theme is conflicting by reactivating them one by one.

#7 @imath
7 days ago

  • Milestone set to Awaiting Contributions

Have you tried to deactivate BuddyPress to see if it was fixing the issue ? I thought you did as you are very positive it's a BuddyPress issue, but re-reading your ticket description, you've not stipulated it.

To me there's no issue on our side.

PS: I'm specifying a milestone to this ticket otherwise it will get lost.

Note: See TracTickets for help on using tickets.