Skip to:
Content

BuddyPress.org

Opened 9 months ago

Closed 9 months ago

Last modified 5 months ago

#8155 closed defect (bug) (fixed)

WordPress required version and travis config update

Reported by: imath Owned by: netweb
Milestone: 6.0.0 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: has-patch commit
Cc:

Description

5.0.0 requires WordPress 4.7.

I suggest BuddyPress 6.0.0 requires 4.8. Is that ok for everyone?

+ I think it would be nice to include WordPress 5.3 into the travis config and eventually remove WordPress 4.7 if we bump required version to 4.8 as suggested.

Attachments (1)

8155.patch (1.7 KB) - added by imath 9 months ago.

Download all attachments as: .zip

Change History (7)

#1 @boonebgorges
9 months ago

  • Keywords dev-feedback removed

Previously: #8025

Following the heuristics at https://codex.buddypress.org/getting-started/wordpress-version-compatibility/, WP 4.8 sounds correct.

Once a WP version is no longer officially supported, it's fine to remove the corresponding Travis jobs. See [12319] for a example. WP 5.3 can be added at any time, independent of this ticket, since the 5.3 branch has been created in Core SVN.

@imath
9 months ago

#2 @imath
9 months ago

  • Keywords has-patch added; needs-patch removed

Hi @boonebgorges

Thanks a lot for your feedback.

#3 @netweb
9 months ago

  • Keywords commit added

LGTM 👍🏼

#4 @imath
9 months ago

Thanks for your feedback @netweb Let's see how it goes :)

#5 @imath
9 months ago

  • Resolution set to fixed
  • Status changed from new to closed

In 12492:

Bump WordPress required version to 4.8 & update Travis configuration

Props boonebgorges, netweb

Fixes #8155

This ticket was mentioned in Slack in #buddypress by imath. View the logs.


5 months ago

Note: See TracTickets for help on using tickets.