Skip to:
Content

BuddyPress.org

Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#8024 closed defect (bug) (worksforme)

Login issues after registration

Reported by: tibbalds Owned by:
Milestone: Priority: high
Severity: critical Version: 4.1.0
Component: Members Keywords: needs-patch has-screenshots
Cc: dsl13@…

Description

Hi,

We’ve been having issues with our site regarding people logging in after registering and logging out previously. How do we fix this? This is quite urgent for us as our site will rely on member participation and we are looking to launch next week (12th).

People can register fine, the email activation link does not work, however if they click on home, they are logged in and can use everything fine. Once they log out and try to log in again it goes to a wordpress login page (screenshot 2) and then, with the correct login details, it does not recognise the user (screenshot 3).

A few more details

  1. Which version of WordPress are you running?

V5

  1. Did you install WordPress as a directory or subdomain install?

We access the wordpress site online

  1. Did you upgrade from a previous version of WordPress? If so, from which version?

No, it’s a new website, build within the last two months

  1. Was WordPress functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting.

Yes, however we installed buddypress early on in the website’s creation.

  1. Which version of BP are you running?

Version 4.1.0

  1. Do you have any plugins other than BuddyPress installed and activated? If so, which ones?

11 plugins (some were installed after the issue first occurred.

Akismet Anti-Spam v4.1
AMP v0.7.2
bbp style pack v4.0.3
bbPress v2.5.14
Contact Form 7 v5.0.5
Custom Twitter Feeds v1.2.10
Flamingo v1.9
Jetpack by WordPress.com v6.8.1
MultiLine files for Contact Form 7 v1.2
Peter’s Login Redirect v2.9.1 (after issue in an attempt to fix)
The Events Calendar v4.7.1

  1. Are you using the standard WordPress theme or customized theme? 10. Which theme do you use ?

Standard theme – Ixion v1.1.5-wpcom

  1. Have you modified the core files in any way?

No

  1. Do you have any custom functions in bp-custom.php?

Not that I know of

  1. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?

bbPress v2.5.14

  1. Please provide a list of any errors in your server’s log files.

Not sure how to access this

  1. Which company provides your hosting?

Wordpress

Screenshot 1
https://people-friendlyplaces.org/wp-content/uploads/2018/12/Screen-Shot-1.png

Screenshot 2
https://people-friendlyplaces.org/wp-content/uploads/2018/12/Screen-Shot-2.png

Screenshot 3
https://people-friendlyplaces.org/wp-content/uploads/2018/12/Screen-Shot-3.png

Change History (8)

#1 @boonebgorges
15 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hello - It appears that you are not running BuddyPress at all. BuddyPress is not offered on wordpress.com (unless you are running VIP). And your screenshots indicate that there are no BP menus in the Dashboard. Perhaps you meant this to be a ticket on bbPress Trac, since you seem to be running bbPress? https://bbpress.org/forums/

For what it's worth, it appears that your problem is linked either to wordpress.com or to Jetpack. I'd suggest reaching out to the Jetpack folks for help: https://jetpack.com/support/

#2 @tibbalds
15 months ago

Hi @boonebgorges

Apologies for the delay in reply, I was away from my computer.

I've installed BuddyPress as a free plugin. Any BuddyPress menus come up in settings. Is this not correct? I have attached further images to what I see in regards to BuddyPress:

https://people-friendlyplaces.org/wp-content/uploads/2018/12/Screen-Shot-2018-12-07-at-19.20.02.png

https://people-friendlyplaces.org/wp-content/uploads/2018/12/Screen-Shot-2018-12-07-at-19.20.25.png

https://people-friendlyplaces.org/wp-content/uploads/2018/12/Screen-Shot-2018-12-07-at-19.20.47.png

#3 @boonebgorges
15 months ago

Thanks - my mistake for not seeing this. However, I still strongly suspect that this doesn't have anything to do with BuddyPress, as BP doesn't modify the way that user login works. I'd recommend testing the same flow with BuddyPress deactivated. If it still doesn't work, then it's a problem outside of BuddyPress.

As noted earlier, I feel fairly confident that this is an issue related to Jetpack's wordpress.com login integration. So another possible thing to test would be to disable Jetpack, or disable that feature in Jetpack, to see if the problem goes away.

#4 @tibbalds
15 months ago

I'll give it a go but isn't it BuddyPress which controls the user membership? Or have I got that wrong?

#5 @tibbalds
15 months ago

@boonebgorges I tried deactivating BuddyPress and this broke the registering and logging in system.

Wordpress does not give me the capability to disable jetpack.

When I first tried to reactivate BuddyPress, it gave me an error message and then worked on the second try:

https://people-friendlyplaces.org/wp-content/uploads/2018/12/Screen-Shot-2018-12-07-at-19.40.19.png

#6 follow-up: @boonebgorges
15 months ago

BuddyPress provides an alternative user-facing interface for the registration process. But user accounts and the login process are all handled by WordPress.

I believe that this specific 403 message comes from wordpress.com. I would recommend reaching out to them for support, as the BP team is unfamiliar with their systems and unable to debug there.

#7 in reply to: ↑ 6 @tibbalds
15 months ago

Replying to boonebgorges:

BuddyPress provides an alternative user-facing interface for the registration process. But user accounts and the login process are all handled by WordPress.

I believe that this specific 403 message comes from wordpress.com. I would recommend reaching out to them for support, as the BP team is unfamiliar with their systems and unable to debug there.

Hi @boonebgorges
I contacted Wordpress and found a solution. I thought I'd post it in case it comes up with someone else again:

That should mean that single sign on is causing trouble. To test that, navigate to My Site --> Settings --> Security in your WordPress.com dashboard, and disable the 'Allow sign in using WordPress.com accounts' option

This means that you will no longer be able to access your wp-admin area with your WordPress.com login information though. We'll need to make sure we set you up with an account for your wp-admin area.

We'll need to set you up with a password for your username for wp-admin.

You'll need to go to WP-Admin > Users and then select your username from the list.

The problem is that on WordPress.com the option to allow WordPress.com sign in replaces the regular registration form that BuddyPress uses to allow users to sign in. So we need to disable this option to let the user's sign in using only their Buddy Press log in without a WordPress.com account.

#8 @boonebgorges
15 months ago

Hi @tibbalds - Glad to hear you've got this sorted out, and thank you for sharing the results!

Note: See TracTickets for help on using tickets.