Skip to:
Content

BuddyPress.org

Opened 20 months ago

Closed 19 months ago

Last modified 15 months ago

#7618 closed task (fixed)

Minimum WP requirements for BP 3.0

Reported by: boonebgorges Owned by: boonebgorges
Milestone: 3.0 Priority: normal
Severity: normal Version:
Component: Core Keywords: 2nd-opinion
Cc:

Description

Time once again to revisit WP requirements. See https://codex.buddypress.org/getting-started/wordpress-version-compatibility/

2.9 supports back to WP 4.4. 4.4 was released in December of 2015 (I remember that one without having to look it up!), so well over a year ago. And usage of 4.4 has slipped just below 5% (4.9% as I read it right now https://wordpress.org/about/stats/). So, I propose that we bump the minimum to 4.5. Any objections?

Change History (5)

#1 @mercime
20 months ago

None :D
DJPaul has removed WP 4.4 testing from .travis.yml in r11682

#2 @boonebgorges
19 months ago

  • Owner set to boonebgorges
  • Resolution set to fixed
  • Status changed from new to closed

In 11745:

BuddyPress 3.0 will require WP 4.5.

Fixes #7618.

#3 @djpaul
15 months ago

In 11955:

Remove further compatibilty checks for unsupported versions of WordPress.

BP 3.0.0 will require WP 4.5+, which lets us assume every site will have oEmbed support.

See #7618 and https://codex.buddypress.org/getting-started/wordpress-version-compatibility/

#4 @djpaul
15 months ago

In 11957:

Remove further compatibilty checks for unsupported versions of WordPress.

BP 3.0.0 will require WP 4.5+, which lets us assume every site will have oEmbed support.

See #7618 and https://codex.buddypress.org/getting-started/wordpress-version-compatibility/

#5 @r-a-y
15 months ago

In 11958:

Activity: After r11957, bring back bp_is_active() check for embeds.

The bp_is_active() check is meant for developers to disable activity
embeds if they do not want that feature enabled on their site.

See #7618.

Note: See TracTickets for help on using tickets.