Skip to:
Content

Changeset 11682


Ignore:
Timestamp:
08/28/2017 02:20:42 PM (19 months ago)
Author:
djpaul
Message:

CI: update Travis-CI configuration.

  • Remove WordPress 4.4 from matrix (we now test only WordPress 4.5+).
  • Remove PHP 5.4, 5.5, 7.0, 7.2 (RC), and nightly, from matrix (we now test only PHP 5.3, 5.6, 7.1).
  • Relocate node_modules folder and cache Node for quicker overall runtime.

The plan is that we test against our supported minimum PHP version, and the latest, as well as the last minor version of an old major branch.
Testing against non-release versions of PHP gives us very little benefit (any issues we are likely to find will cause problems in WordPress, and that team are more competent than us to report such issues upstream to PHP).

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/.travis.yml

    r11674 r11682  
    1414    - vendor
    1515    - $HOME/.composer/cache
    16 #    - /tmp/wordpress/src/wp-content/plugins/buddypress/node_modules
     16    - /tmp/node_modules
     17
     18git:
     19  depth: 1
    1720
    1821php:
    1922  - 7.1
    20   - 7.0
    2123  - 5.6
    22   - 5.5
    23   - 5.4
    2424
    2525# WordPress comes from the Git mirror, where 'master' mirrors svn 'trunk' and
     
    3131  - WP_VERSION=4.6 BP_TRAVISCI=travis:phpunit
    3232  - WP_VERSION=4.5 BP_TRAVISCI=travis:phpunit
    33   - WP_VERSION=4.4 BP_TRAVISCI=travis:phpunit
    3433
    3534matrix:
    3635  include:
    37     - php: 7.2
    38       env: WP_VERSION=master BP_TRAVISCI=travis:phpunit
    39     - php: nightly
    40       env: WP_VERSION=master BP_TRAVISCI=travis:phpunit
    41     - php: 7.0
    42       env: WP_VERSION=master BP_TRAVISCI=travis:grunt
    43     - php: 7.0
     36    - php: 7.1
    4437      env: WP_VERSION=master BP_TRAVISCI=travis:codecoverage
    4538    - php: 5.3
     
    5851      env: WP_VERSION=4.5 BP_TRAVISCI=travis:phpunit
    5952      dist: precise
    60     - php: 5.3
    61       env: WP_VERSION=4.4 BP_TRAVISCI=travis:phpunit
    62       dist: precise
    6353  exclude:
    6454    - php: 7.1
     
    6656    - php: 7.1
    6757      env: WP_VERSION=4.5 BP_TRAVISCI=travis:phpunit
    68     - php: 7.1
    69       env: WP_VERSION=4.4 BP_TRAVISCI=travis:phpunit
    7058  allow_failures:
    71     - php: 7.2
    72     - php: nightly
    7359    - env: WP_VERSION=master BP_TRAVISCI=travis:codecoverage
     60
    7461# before_install: Failures in this section will result in build status 'errored'
    7562before_install:
     
    8976      echo "We are running codecoverage or xdebug.ini does not exist"
    9077    fi
     78
    9179  # set up tests config
    9280  - cd $WP_DEVELOP_DIR
     
    9684  - sed -i "s/yourusernamehere/root/" wp-tests-config.php
    9785  - sed -i "s/yourpasswordhere//" wp-tests-config.php
     86
    9887  # set up database
    9988  - mysql -e 'CREATE DATABASE wordpress_test;' -uroot
     89
    10090  # prepare for running the tests
    10191  - cd $plugin_dir
     92
    10293  # setup NodeJS version using NVM
    10394  - node --version
    10495  - nvm install 6
    10596  - node --version
     97  - npm config set prefix "/tmp/node"
     98  - export PATH="$HOME/.composer/vendor/bin:/tmp/node/bin:$PATH"
    10699  - npm install -g grunt-cli
    107100  - npm --version
     
    118111# before_script: Failures in this section will result in build status 'errored'
    119112before_script:
    120   - export PATH="$HOME/.composer/vendor/bin:$PATH"
    121113  - if [[ ${TRAVIS_PHP_VERSION:0:3} == "5.3" ]]; then composer global require --dev phpunit/phpunit ^4; fi
    122   - if [[ ${TRAVIS_PHP_VERSION:0:3} == "5.4" ]]; then composer global require --dev phpunit/phpunit ^4; fi
    123   - if [[ ${TRAVIS_PHP_VERSION:0:3} == "5.5" ]]; then composer global require --dev phpunit/phpunit ^4; fi
    124114  - if [[ ${TRAVIS_PHP_VERSION:0:3} == "5.6" ]]; then composer global require --dev phpunit/phpunit ^5; fi
    125   - if [[ ${TRAVIS_PHP_VERSION:0:3} == "7.0" && $WP_VERSION == "4.4" ]]; then composer global require --dev phpunit/phpunit ^5; fi
    126   - if [[ ${TRAVIS_PHP_VERSION:0:3} == "7.0" && $WP_VERSION == "4.5" ]]; then composer global require --dev phpunit/phpunit ^5; fi
    127   - if [[ ${TRAVIS_PHP_VERSION:0:3} == "7.0" && $WP_VERSION == "4.6" ]]; then composer global require --dev phpunit/phpunit ^5; fi
    128   - if [[ ${TRAVIS_PHP_VERSION:0:3} == "7.0" && $WP_VERSION == "4.7" ]]; then composer global require --dev phpunit/phpunit ^6; fi
    129   - if [[ ${TRAVIS_PHP_VERSION:0:3} == "7.0" && $WP_VERSION == "4.8" ]]; then composer global require --dev phpunit/phpunit ^6; fi
    130   - if [[ ${TRAVIS_PHP_VERSION:0:3} == "7.0" && $WP_VERSION == "master" ]]; then composer global require --dev phpunit/phpunit ^6; fi
    131115  - if [[ ${TRAVIS_PHP_VERSION:0:3} == "7.1" ]]; then composer global require --dev phpunit/phpunit ^6; fi
    132   - if [[ ${TRAVIS_PHP_VERSION:0:3} == "7.2" ]]; then composer global require --dev phpunit/phpunit ^6; fi
    133116  - npm install
     117
    134118# Run tests
    135119script: grunt $BP_TRAVISCI
Note: See TracChangeset for help on using the changeset viewer.