Skip to:
Content

BuddyPress.org

Opened 3 years ago

Closed 3 years ago

#7252 closed defect (bug) (fixed)

Missing colon in string

Reported by: SGr33n Owned by: djpaul
Milestone: 2.8 Priority: lowest
Severity: trivial Version:
Component: I18N Keywords: needs-patch good-first-bug
Cc:

Description

Hi people,

In the following string

https://translate.wordpress.org/projects/wp-plugins/buddypress/dev/it/default?filters[status]=either&filters[original_id]=2290779&filters[translation_id]=39879704

I suppose there is a missing colon on the row:
To learn more about the group, visit group.url.
Should it be:
To learn more about the group, visit: group.url.

Is it right?

Thanks!

Attachments (1)

7252.patch (1.4 KB) - added by sanket.parmar 3 years ago.

Download all attachments as: .zip

Change History (10)

#1 @danbp
3 years ago

I controlled the french translation to see if there is a similar issue.

I found that almost all email text containing quotes are marked as fuzzy.

Ie. the original string shows hello "group"
the string marked as fuzzy shows hello "group"

On other strings using quotes, i have "word" in original and translation.

I don't thing that the double point is the issue but the quotes used immediatly after. And this in not all strings using quotes.

Example here: https://translate.wordpress.org/projects/wp-plugins/buddypress/dev/fr/default?page=15

#2 @danbp
3 years ago

Double checked translation and found another possible reason.

I haven't see that first (f... contrast) but they are blank spaces in the original strings. Look after "accepted" !

Your membership request for the group "{{group.name}}" has been accepted.↵ ↵ To view the group, visit: {{{group.url }}}

The fuzzy one

Votre demande d'adhésion au groupe "{{group.name}}" a été acceptée. Voir le groupe: {{{group.url }}}

This ticket was mentioned in Slack in #buddypress by danbp. View the logs.


3 years ago

#4 @slaFFik
3 years ago

Quotes change is caused by the ticket #6949 and r10956.

#5 @danbp
3 years ago

Would ENT_NOQUOTES do the trick with htmlentities() ?

I tested following string with htmlentities() here: https://en.functions-online.com/htmlentities.html

string htmlentities ( string $str [, int $quote_style ] [, string $charset ] )

String:

{{poster.name}} replied to one of your comments:

"{{usermessage}}"

Quote_style: ENT_NOQUOTES

Charset: UTF-8

This returns a correct value.
BuddyPress doesn't use nowhere htmlentities or htmlspecialchars.
bbPress use htmlspecialchars in a few files.

#6 @DJPaul
3 years ago

I think this is off-topic -- the reporter asked about whether a string should have a colon in it. Right?

In reply to @SGr33n, I wouldn't call this a bug, but if you think the sentence is better that way, I've no problems changing it, as long as we're consistent with the other emails.

#7 @SGr33n
3 years ago

I see that every "visit url" has a colon, this looks the only one whithout, just for consistence. Sorry for this is not a bug, I will report this on the slack channel the next time.

#8 @DJPaul
3 years ago

  • Keywords needs-patch good-first-bug added
  • Milestone changed from Awaiting Review to 2.8
  • Priority changed from normal to lowest
  • Severity changed from normal to trivial

OK, let's add the colon into the string for consistency. I'll get this done in 2.8, but anyone is welcome to provide a patch for easy props, it should be pretty trivial. :)

@sanket.parmar
3 years ago

#9 @djpaul
3 years ago

  • Owner set to djpaul
  • Resolution set to fixed
  • Status changed from new to closed

In 11285:

Emails: fix consistent use of colon before links in notifications.

Fixes #7252

Props danbp, sanket.parmar

Note: See TracTickets for help on using tickets.