Skip to:
Content

BuddyPress.org

Opened 3 years ago

Closed 3 years ago

#7098 closed defect (bug) (no action required)

Foreign quotation mark - guillemet issue

Reported by: danbp Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords: close
Cc: danco38@…

Description

First, it's a very obvious issue i found in a topic activity on my SWA.
Second, it may (perhaps) be difficult to replicate with an english OS & keyboard. In both case, please see the joined screenshots.

I tested guillemets within topics, updates and post and with different themes and site languages (en & fr)with various results. See attached txt file to get some text to copy/paste for testing.

The issue:
in french we use guillemet to quote words, while in english double quotes are used. WP does this automatically depending the site language.
Visually, left and right guillemet are very different from quotes, which are very similar. So the issue is not really visible in english. (doesn't mean it is inexistent).

When quoting a word inside a phrase or which is the last one, i have a correct ouput of open & closing guillemets. Same result when quoting a linked word inside a phrase.

When quoting a linked word which is at the end of a phrase, the quotes are wrong. They're 2 left quotes, aka opening quotes instead of a left and a right quote.

If i remember well, there was a similar issue in the past (around BP 1.2.8 or so) with foreign quote marks.

Attachments (6)

en_quote_screen.jpg (46.7 KB) - added by danbp 3 years ago.
English quotes
fr_quote_screen.jpg (47.0 KB) - added by danbp 3 years ago.
French quotes
update_quote_screen.jpg (56.5 KB) - added by danbp 3 years ago.
update quotes
post_quote_screen.jpg (87.7 KB) - added by danbp 3 years ago.
post quote
guillemet_text_test.txt (1.2 KB) - added by danbp 3 years ago.
Fake text with different quotes examples
guillemet_activities.jpg (24.1 KB) - added by danbp 3 years ago.
Activities

Download all attachments as: .zip

Change History (16)

@danbp
3 years ago

English quotes

@danbp
3 years ago

French quotes

@danbp
3 years ago

update quotes

@danbp
3 years ago

post quote

@danbp
3 years ago

Fake text with different quotes examples

#1 @boonebgorges
3 years ago

  • Keywords needs-patch needs-unit-tests added

Previously: [8156], #2776

At a glance, the issue is not necessarily that the linked word is at the end of the string, but that's it's followed directly by a period.

#2 @danbp
3 years ago

  • Cc danco38@… added

#3 @danbp
3 years ago

With or without a period doesn't change the issue.
I digged further and found an interesting point (See attachment.).

if you publish an update and a topic using the following:

1) un \"<a href="#">lien</a>\" entre guillemets avec slashs

2) un "<a href="#">lien</a>" entre guillemets

3) un "<a href="#">lien</a>"

Note that the text is correctly inserted as is in both activity and post table.
I added slashes intentionnaly to 1)

1) on the forum activity, slashes are not removed and a wrong left (opening) guillemet is visible. On SWA, text is cleaned and use correct guillemets.

2) is correct on Forum and SWA with a sequence of linked text + text

3) output is wrong on Forum and SWA; A quoted link without period.

@danbp
3 years ago

Activities

#4 @xibe
3 years ago

Looks like the issue I've been trying to get known since 2009: http://xavier.borderie.net/wp-trunk/?p=56

Several WP tickets about it. Here's one: https://core.trac.wordpress.org/ticket/4539

It seems like the issue comes from wptexturize. I'd love to see it fixed, but my PHP- and -regexp-fu are not good enough :/

This ticket was mentioned in Slack in #buddypress by danbp. View the logs.


3 years ago

#6 @DJPaul
3 years ago

  • Component changed from General - UX/UI to Core

#7 @r-a-y
3 years ago

@danbp - Are you able to duplicate this issue in a WordPress post?

I think @xibe maybe right that this is probably a wptexturize() issue.

#8 @danbp
3 years ago

@r-a-y,

yes i can. See screenshots

i posted the example i already mentionned in #3 (wp 4.5.3 - 2016)
example 1 and 3 are wrong. 2 is correct.

2nd screenshot shows the post activity on SWA. Guillemets are all correct.

Screen 1

http://bp-fr.net/wp-content/uploads/2016/06/post_guillemet_test_.jpg

Screen 2

http://bp-fr.net/wp-content/uploads/2016/06/swa_guillemet_test.jpg

#9 @r-a-y
3 years ago

  • Keywords close added; needs-patch needs-unit-tests removed

Thanks for the updated info, @danbp.

This confirms that the issue is with WordPress and not BuddyPress.

#10 @DJPaul
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Let's let WordPress tackle this one.

Note: See TracTickets for help on using tickets.