Skip to:
Content

Opened 2 years ago

Last modified 8 months ago

#6832 reopened defect (bug)

Error Posting comments

Reported by: mjc82in Owned by:
Milestone: Priority: high
Severity: normal Version:
Component: Core Keywords: reporter-feedback needs-testing
Cc:

Description

i,

I have been having this error for couple of months or more, have narrowed it down to being a buddypress error.

Error is
Whenever somebody posts comments, the comments go through (i.e it does get posted)
But as soon as user hits post button, it thinks for a min and gets forwarded to an error page(sometimes show duplicate comment).

Any idea to solve, This is becoming a very serious issue, have been talking with Automattic as well. Can somebody help me resolve this.

Thanks
Manoj

Change History (17)

#1 @mercime
2 years ago

  • Milestone Awaiting Review deleted
  • Status changed from new to closed

duplicate of #6776

#2 @mjc82in
2 years ago

  • Status changed from closed to reopened

The problem has not been resolved and its becoming more and more critical now.
I narrowed down the issue to site tracking. Whenever I have site tracking on buddypress turned on. the error happens if not it works.

#3 @r-a-y
2 years ago

  • Status changed from reopened to closed

Hi mjc82in,

Your ticket was marked as a duplicate of #6776.

Please leave updated responses there to prevent forking the discussion.

Thanks!

#4 @mjc82in
2 years ago

Nobody seems to responding on the other chat, and this is a critical issue. More and more its looking like bug which is why I posted here. Trying to get a faster response.

#5 @hnla
2 years ago

Multiple posts in different places will have the reverse effect you are after, they will not speed up attention, just serve to fracture the discussions across those various threads.

This ticket is closed so either the forum ( the proper place to begin until it's established as a bug ) or the other ticket is the place to continue.

I realise it may be frustrating, but the lack of responses may be partly due to not being able to reproduce the issue, so please ensure and acknowledge for definite that you are testing in ? twentyfifteen, NO plugins activated except BP and the literal steps to produce an error ( run askimet if you're sure it's a factor).

#6 @mjc82in
2 years ago

  • Status changed from closed to reopened

Hi,

I have narrowed it down and determined its a bug. but not sure how to resolve it, not getting any response on the other forum. Starting to get pressures from all the faculty as its a core functionality on the course.
The issue happen when during comment update, "_bp_akismet_submission" is being added to the wp_bp_activity_meta. It does not get added and heres where the error happens.

#7 @r-a-y
2 years ago

  • Keywords reporter-feedback needs-testing added
  • Milestone set to Awaiting Review
  • Priority changed from highest to normal
  • Severity changed from critical to normal
  • Version 2.4.0 deleted

Thanks for narrowing down the bug, @mjc82in.

Someone will need to replicate the issue to confirm your problem.

Can you please write a detailed list of steps to duplicate your issue?

For example:

1. Go to the Activity directory page (`example.com/activity/`)
2. Create a new activity status update.
3. Create a comment for that status update.
...

The clearer you are, the better we can spend our time to help.

#8 @mjc82in
2 years ago

Issue happens in all our sites.
Go to a post (that allows comments for logged in users)
Try to comment gives error page or duplicate post page.

Look like the issue is in bp-activity-akismet.php line 488
bp_activity_update_meta( $activity->id, '_bp_akismet_submission', $this->last_activity->akismet_submission );
The above command throws out the error and I did notice that "_bp_akismet_submission" does not get added to the wp_bp_activity_meta table.

#9 @r-a-y
2 years ago

Try to comment gives error page or duplicate post page.

I am assuming you mean "Go to a blog post that has comments enabled and attempt to post a comment on that blog post".

I tried this on both BuddyPress 2.4.3 and BuddyPress 2.5-beta1 with the Twenty Twelve theme and do not get an error page.

Can you post a screenshot of the error or list the error that you see?

I think your specific error is due to a plugin or theme conflict.

I echo what hnla wrote in comment:5. Disable all unnecessary plugins and switch your theme to one of the WordPress default themes. Then, try to duplicate your issue. This will save us all time.

Look like the issue is in bp-activity-akismet.php line 488

If you are encountering an error because of Akismet, for now, I would recommend disabling Akismet support for BuddyPress activity items.

You can do this by going to "Settings > BuddyPress". Then, click on the "Settings" tab. Scroll down to "Activity Settings" and uncheck the "Akismet" option.

Are you using the latest version of Akismet? The problem might be due to a change with Akismet, but one of us will need to verify.

#10 @mjc82in
2 years ago

I am running the latest version of everything.

Not Sure if its the right way of doing it, but I finally resolved the issue today.

In bp_activity_functions.php file, bp_activity_update_meta function

added this line
"$meta_value = wp_unslash($meta_value);"
when $meta_key == '_bp_akismet_submission'
before this line
"$retval = update_metadata( 'activity', $activity_id, $meta_key, $meta_value, $prev_value );"

And it works.

#11 @DJPaul
22 months ago

I cannot see how changing the bp_activity_update_meta function in that way didn't break *every* other piece of activity meta that BuddyPress tries to set, but what's done is done.

@r-a-y Did you actually test this with Akismet, with both spam and no-spam responses?

#12 @DJPaul
19 months ago

  • Component changed from API to Core

#13 @DJPaul
19 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

I still can't reproduce. @mjc82in, we've asked you twice for a list of plugins you have active, as well as a screenshot of the error (or transcription of the error message), and trying to recreate the issue on a default WordPress theme (if you have a dev site or testing site you can borrow). I'm going to ask you a third time, because we are really struggling to pin down what might be happening, we can't reproduce any problems as it stands. Our current best guess is that there must be a plugin or theme conflict, but that doesn't help us identify what.

I think we'll need to wait for another report of this problem happening, so we can narrow down possible causes, or more information from @mjc82in. As @r-a-y pointed out, you can disable BuddyPress' Akismet integration in our Settings screen, which will save you having to make modifications to the plugin every time you update it.

Until then, I'm going to close this ticket as we haven't been able to reproduce it and require more information.

#14 @mjc82in
17 months ago

  • Priority changed from normal to high
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Hi, After my manual fix it was working then When I did the last updates it seemed to work fine but after the latest update the problem is back.
I tried mix and match of removing plugin,only plugin that seemed to affect this is buddypress and akismet when both are active this problem occurs. As I mentioned earlier at what point this error occurs.

What kind of error is very Random no logic to it as far as I am concerned. Sometime error page, sometimes duplicate comments error. As far as the comments is concerned it gets posted.

In sequence.
I navigate to a post and comment on it.
When I hit submit
Looks like comment gets authenticated and posted.
but but does not redirected back to the page, ( It looks like its crashing when storing some value into the database.)

#15 @mercime
17 months ago

@mjc82in Sorry to learn that you are still having that issue.

When you mentioned "did the last updates", are you now on WP 4.5.3 and BP 2.6.2?
Aside from the versions, are the answers you posted in https://buddypress.org/support/topic/error-posting-comments-2/#post-248911 (ref in #6776)including errors still the same?“

#16 @mjc82in
17 months ago

The errors are all the same.

I am assuming the previous update did not change the file changes I corrected and the new update changed the file.

So In short I am guessing was never fixed.

#17 @tw2113
8 months ago

Reading through this thread, I am very honestly curious what sort of things would be appearing in error logs when the errors occur, if anything. That type of information would provide a lot more ideas of what's going on and what actually needs to change, as well as why.

Note: See TracTickets for help on using tickets.