Skip to:
Content

BuddyPress.org

Opened 4 years ago

Closed 4 years ago

#6776 closed defect (bug)

Error Posting comments

Reported by: mjc82in Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Blogs Keywords:
Cc:

Description

Hi,

I have been having this error for couple of months or more, have narrowed it down to being a buddypress error.

Error is
Whenever somebody posts comments, the comments go through (i.e it does get posted)
But as soon as user hits post button, it thinks for a min and gets forwarded to an error page(sometimes show duplicate comment).

Any idea to solve, This is becoming a very serious issue, have been talking with Automattic as well. Can somebody help me resolve this.

Thanks
Manoj

Change History (6)

#1 @DJPaul
4 years ago

Forum mods, have we seen any other reports of anything like this in the last couple of months?

#2 @mercime
4 years ago

#6832 was marked as duplicate

#3 @mercime
4 years ago

@mjc82in Saw you post at https://buddypress.org/support/topic/error-posting-comments-2/ Do provide the information requested there. Thanks.

#4 @hnla
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

@mjc82in The correct place to look into this initially is the community help forum where you'll get the widest exposure for the problem, I see you've opened a thread there:
https://buddypress.org/support/topic/error-posting-comments-2/

If you could elaborate on the steps to re-produce so it's absolutely clear what the issue is and how to re-create it would help others look into this.

In a very brief test, I can add a comment to a post via the activity stream, this posts without issue in both act stream and the original post, I can add a comment to the post and likewise this is submitted correctly and synced to activity stream.

So I'm not sure if there is an issue without verifying exact steps to reproduce, also naturally ensure no plugins running and a default WP theme in use, if you could detail those steps and acknowledge re-testing with plain WP theme on the forum thread it will help.

If we do find an issue we will create a trac ticket to cover it.

Going to close this ticket in favour of the forum thread for the moment.

#5 @r-a-y
4 years ago

  • Component changed from API to Component - Blogs
  • Milestone set to Awaiting Review
  • Resolution worksforme deleted
  • Status changed from closed to reopened

mjc82in added a new comment on #6832:

The problem has not been resolved and its becoming more and more critical now.
I narrowed down the issue to site tracking. Whenever I have site tracking on buddypress turned on. the error happens if not it works.


@mjc82in - To follow-up with what hnla mentioned above, you need to write a clear list of steps to reproduce the problem, what the expected behavior is and what is actually occurring.

I would also guess from what you mentioned here:

But as soon as user hits post button, it thinks for a min and gets forwarded to an error page(sometimes show duplicate comment).

That your problem is due to your theme or a plugin conflict. I would recommend switching your theme to a WordPress default theme like Twenty Fourteen and see if you are able to duplicate your problem.

#6 @r-a-y
4 years ago

  • Milestone Awaiting Review deleted
  • Status changed from reopened to closed

Closing this as OP is replying to the other ticket - #6832.

Note: See TracTickets for help on using tickets.