Skip to:
Content

BuddyPress.org

Opened 5 years ago

Closed 5 years ago

#6477 closed defect (bug) (fixed)

User domains don't resolve correctly with BP_ENABLE_ROOT_PROFILES when Members page is not top-level

Reported by: boonebgorges Owned by: r-a-y
Milestone: 2.4 Priority: normal
Severity: normal Version:
Component: Route Parser Keywords: has-patch commit
Cc:

Description

See #6475 for previous report.

Steps to reproduce:

  • define( 'BP_ENABLE_ROOT_PROFILES', true ); in wp-config.php
  • Make your Members page a child of another page
  • Try to visit the domain of a specific user (eg, example.com/boone)

Expected: you see the user's page
Actual: you see the Members directory

Attachments (2)

6477.diff (1.7 KB) - added by boonebgorges 5 years ago.
6477.02.patch (2.2 KB) - added by r-a-y 5 years ago.

Download all attachments as: .zip

Change History (8)

@boonebgorges
5 years ago

#1 @boonebgorges
5 years ago

  • Keywords has-patch needs-testing added

6477.diff ports the fix for the problem from r-a-y's patch on #6475 https://buddypress.trac.wordpress.org/attachment/ticket/6475/6475.01.patch, and adds a unit test. (The rest of his suggested fixes in that patch are performance-related, and probably deserve a separate ticket, since they're much more expansive.)

@r-a-y
5 years ago

#2 @r-a-y
5 years ago

The rest of his suggested fixes in that patch are performance-related, and probably deserve a separate ticket, since they're much more expansive.

I wouldn't really say "much more expansive", but I get your point :) I've ported over the additional performance tweak into 02.patch, just so it isn't lost.

#3 @espellcaste
5 years ago

I had this problem recently. I solved not putting it as a child of another page. But wasn't sure it was a bug in BuddyPress or somewhere in my code or another plugin.

This ticket was mentioned in Slack in #buddypress by boone. View the logs.


5 years ago

#5 @boonebgorges
5 years ago

  • Keywords commit added; needs-testing removed

Looks good to me.

#6 @r-a-y
5 years ago

  • Owner set to r-a-y
  • Resolution set to fixed
  • Status changed from new to closed

In 10212:

URI: Allow root profiles to work when the 'Members' page is nested.

Previously, if the Members page was nested as a child of another page, the
root profiles feature - define( 'BP_ENABLE_ROOT_PROFILES', true ); - did
not work. This commit fixes this and includes a unit test.

Commit also adds a minor performance tweak when a root profile is detected.

Props r-a-y, boonebgorges.

Fixes #6477.

Note: See TracTickets for help on using tickets.