Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 4 years ago

#5841 closed enhancement (maybelater)

Don't force BuddyPress profile on all WordPress users

Reported by: sooskriszta Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Members Keywords: trac-tidy-2018
Cc: sooskriszta

Description

Say I have a WordPress site at domain.com The site also has a portion powered by BuddyPress.

Often, while I want the BuddyPress/community portion to be public, I don’t want every WordPress-registered user to automatically also have a BuddyPress profile page.

In WordPress Admin area, there should be a way to assign BuddyPress roles. Only folks that have BuddyPress roles should be assigned profiles.

Change History (9)

#1 @DJPaul
7 years ago

  • Keywords reporter-feedback added

We'll give this suggestion some consideration, but I suspect it might end up being resolved as something that we don't want to do in BuddyPress core, but that it would make a good plugin.

Can you give more details about how you use BuddyPress on your site, to help us understand what type of/how many users you'd want to not have a profile vs. how many you do? Thanks.

#2 @sooskriszta
7 years ago

  • Keywords reporter-feedback removed

There are a couple of use-cases

  1. On some sites, we want to have administrators and developers registered in BuddyPress, but who shouldn't have profiles, and shouldn't be listed under groups (though they own the groups)
  2. On some sites that are WP-based CMS as well as Community sites, often people would register just to comment on pages or posts, while the community is more specialized. Folks that just want to comment shouldn't necessarily get BP profiles.

#3 @DJPaul
7 years ago

  • Keywords 2nd-opinion added

Your first suggested use case resonates with me much more than the second; i'm imagining a filter or checkbox option, etc, that lets you make certain users invisible. I have heard similar requests while working on other plugins (not BuddyPress), so I think it merits further consideration. The implementation might prove challenging, but that can be considered in due course if we want to accept this suggestion.

#4 @sooskriszta
7 years ago

Let me give a more vivid example of the second use case:
Say a small business sets up its website using WordPress. So, primarily using WordPress as CMS. There may also be a blog, say for press releases or newsletters archive or some such. On posts and some pages, they allow visitors to comment.
Happy with WordPress, the company decides to move its Intranet from Google Sites to WordPress using BuddyPress. Oh, but the problem is that if I go to Members page, all the registered commenters/visitors are listed as well. Sure, there are some workarounds, but it would be nice if this were cleanly done by BuddyPress.

#5 @boonebgorges
7 years ago

A fairly straightforward change we could make at a low level is to put a filter into our URL parser, which would run just after a /members/ URL had been detected. Plugins could filter it and return false for certain classes of users that aren't intended to have profile pages.

#6 @DJPaul
7 years ago

  • Keywords 2nd-opinion removed
  • Milestone changed from Awaiting Review to Future Release

Let's go with a filter for now, and we can think about a core option in the future; plus it would allow someone to make a (popular) plugin. :)

#7 @sooskriszta
7 years ago

This has perhaps been made easier by #6006

#8 @DJPaul
4 years ago

  • Keywords trac-tidy-2018 added

We're closing this ticket because it has not received any contribution or comments for at least two years. We have decided that it is better to close tickets that are good ideas, which have not gotten (or are unlikely to get) contributions, rather than keep things open indefinitely. This will help us share a more realistic roadmap for BuddyPress with you.

Everyone very much appreciates the time and effort that you spent sharing your idea with us. On behalf of the entire BuddyPress team, thank you.

If you feel strongly that this enhancement should still be added to BuddyPress, and you are able to contribute effort towards it, we encourage you to re-open the ticket, or start a discussion about it in our Slack channel. Please consider that time has proven that good ideas without contributions do not get built.

For more information, see https://bpdevel.wordpress.com/2018/01/21/our-awaiting-contributions-milestone-contains/
or find us on Slack, in the #buddypress channel: https://make.wordpress.org/chat/

#9 @DJPaul
4 years ago

  • Milestone Awaiting Contributions deleted
  • Resolution set to maybelater
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.