Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 5 years ago

#5560 closed defect (bug) (fixed)

Blog Comment Sync Activity removes Filter and Click-through functionality

Reported by: mrjarbenne Owned by:
Milestone: 2.0.1 Priority: normal
Severity: normal Version: 2.0
Component: Activity Keywords: has-patch needs-testing
Cc: r-a-y

Description

In BP 2.0, comments left on the post update on the activity feed, for a network blog, now populate the comment area of the blog (awesome).

With that functionality turned on, comments left on the blog, now show up as a new "Activity Comment" in the activity stream, rather than a "(username) commented on the post (postURL)".

This means that there is no longer a way to directly get to that comment on the blog, because the "activity comment" line doesn't contain the URL link back the network blog. When you click the "view conversation" button, you are taken to the conversation, and can then go to the blog via the conversation view "header", but this adds an additional click if I want to go right to the blog, from a comment in the activity feed.

Additionally, those Activity Comments don't get filtered when you select "Comments" on the activity feed "Show:" filter. They only appear in the stream when you select "Everything", so there is no longer a way to show only the comments someone has left on the other blogs in the network.

Comments left on a blog, whether via the activity stream, or on the blog itself, should still populate the activity stream as they would if the activity sync was not on, with an "[username] commented on the post [posturl] on [siteurl]"

Attachments (1)

5560.01.patch (3.4 KB) - added by r-a-y 6 years ago.

Download all attachments as: .zip

Change History (10)

#1 @boonebgorges
6 years ago

  • Cc r-a-y added
  • Component changed from Core to Activity
  • Milestone changed from Awaiting Review to 2.1

mrjarbenne - Thanks for the report.

r-a-y - Do you have thoughts about this? I think the feedback is valid. We could approach it as requiring a couple interface tweaks:

  1. Add something to the interface that will allow linking to the blog post from within the activity reply. Maybe like a '#' link.
  2. When 'Blog Comments' is selected in the activity stream dropdown, switch to show_comments=threaded

I've seen a related comment in a few places along the lines of: activity replies don't push the parent to the top of the thread, so blog comments are not as visible in 2.0 (as when they were standalone activity items). I wonder if solving *that* problem - say, using the thread-last-updated date for ordering recent activity items, and then doing something in the interface to show which comments are newest - would go some way toward solving the visibility/accessibility issues that mrjarbenne is raising here.

Putting into 2.1 for further discussion.

@r-a-y
6 years ago

#2 @r-a-y
6 years ago

  • Keywords has-patch added

01.patch addresses everything mrjarbenne mentioned.

  1. "admin posted a new activity comment" is now formatted to use the old 'new_blog_comment' activity action callback for those activity comments connected to blog comments. (eg. "admin commented on the post, X")
  2. These activity items now use the comment permalink instead of the activity thread permalink
  3. Using the "Comments" dropdown filter now filters activity comments associated with blog comments.

I think this could go into 2.0.1.


activity replies don't push the parent to the top of the thread, so blog comments are not as visible in 2.0 (as when they were standalone activity items)

No bump to the top stuff is done in the main activity directory in this patch though. Need to think more about this.

#3 @boonebgorges
6 years ago

  • Keywords needs-testing added
  • Milestone changed from 2.1 to 2.0.1

I think this could go into 2.0.1.

Yeah. The more I think about it, the more I think these are regressions. I think your fixes look good at a glance. I'll try to test them more thoroughly in the next day or two.

No bump to the top stuff is done in the main activity directory in this patch though. Need to think more about this.

Yeah, definitely. I was just raising it as a possibly related concern. Probably deserves its own ticket for consideration.

#4 @r-a-y
5 years ago

Just going to revisit the points I mentioned in comment:2:

(tl:dr - point 2 should be committed, the rest should be bumped)

Point 1 - Action formatting for activity comments associated with blog posts

I wanted to reuse our blog comment activity action callback, however this technique is a little iffy because if a blog post modifies its title, the activity meta (which houses the blog and post's URL and name) for the activity comment will not be updated.

Point 2 - Switching the primary link for activity comments associated with blog posts to the comment permalink

I think this one is good to go. But, I think we need to do a better job of recording the blog comment's permalink as I don't think our code handles comment pagination when re-recording the primary link.

Point 3 - "Comments" dropdown filter

After discussing this issue with mrjarbenne, he brings up a good point about the "Comments" dropdown filter.

In my patch, I switch to filtering only activity comments associated with blog posts and not old-school "new_blog_comment" singular entries. However, it might be beneficial if the "Comemnts" dropdown option filtered both types of comments - "new_blog_comment" entries and activity comments associated with blog posts.

This brings up a larger issue with supporting both types of comment systems at the same time. Right now, if you enable activity stream commenting, this disables the recording of separate "new_blog_comment" entries.

#5 @boonebgorges
5 years ago

But, I think we need to do a better job of recording the blog comment's permalink as I don't think our code handles comment pagination when re-recording the primary link.

Do you know a reliable way to generate this link? I'm guessing that it'll be too resource-intensive to do in the loop - we'll probably have to do this when we generate the primary_link for the original activity item.

This ticket was mentioned in IRC in #buddypress-dev by boonebgorges. View the logs.


5 years ago

#7 @r-a-y
5 years ago

In 8344:

Blogs: Formatting improvements for activity comments connected to blog comments.

This commit:

  • Readjusts the permalink for singular activity comments connected to blog comments to use the comment permalink instead of the activity thread permalink
  • Readjusts the activity action for singular activity comments connected to blog comments to use the familiar blog comment action instead of the generic "posted an activity comment" action

See #5560 (2.0-branch)

#8 @r-a-y
5 years ago

In 8345:

Blogs: Formatting improvements for activity comments connected to blog comments.

This commit:

  • Readjusts the permalink for singular activity comments connected to blog comments to use the comment permalink instead of the activity thread permalink
  • Readjusts the activity action for singular activity comments connected to blog comments to use the familiar blog comment action instead of the generic "posted an activity comment" action

See #5560 (trunk)

#9 @boonebgorges
5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Thanks very much, all. I've opened separate tickets for the 'New Blog Comments' filter issue (#5608) and the activitymeta invalidation issue (#5609). Let's work on those for 2.1, and close this one to keep the 2.0.1 clean.

Note: See TracTickets for help on using tickets.