Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#4983 closed enhancement (duplicate)

Many nested comments on a single activity stream item

Reported by: henrywright Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.7
Component: Core Keywords: needs-patch
Cc: karmatosed@…

Description

http://testbp.org/members/henrywright/activity/226291/

Too many nested comments results in activity stream items looking squashed.

After about the 10th nested reply, the comments are unreadable.

Change History (11)

#1 @karmatosed
8 years ago

  • Keywords changed from nested comments, nested replies to nested comments nested replies

I would say this really is down to the theme really now with theme compat. However, with the new template pack we're doing I definitely think this is one thing we can address there. It's a persistent issue with nested comments and finding a theme independent way could be a good challenge to undertake there.

#2 @karmatosed
8 years ago

  • Cc karmatosed@… added

#3 @henrywright
8 years ago

@karmatosed

Agreed! Finding a good way to display nested comments will be challenging. Now that theme compat is in place the responsibility will be down to theme authors to get it right. I'm sure you guys will set a good example with the new template pack you're doing! looking forward to it...

#4 @boonebgorges
8 years ago

  • Keywords needs-patch added; nested comments nested replies removed
  • Milestone changed from Awaiting Review to 1.9

WP has a setting (Settings > Discussion) for the level of nesting permitted in comment threads. I don't think BP needs an admin-level option for this, but it does make sense to make a cap possible, and to put a filter in there. This would be pretty easy at the level of the PHP, though it would take some refactoring of how the JS works.

Putting this into 1.9 for review in connection with the new template packs. karmatosed, if you need any core changes in order to make this kind of limit possible, don't hesitate to post a patch or make a request here.

#5 @karmatosed
8 years ago

I suggest we mark this to be for version 2.0 as the template pack will have some solution (not sure what yet) for nested comments.

#6 @henrywright
8 years ago

Perhaps a good approach is to not indent them. Indentation is the source of this problem here so finding another way to show the comment is a child comment could be the solution.

#7 @karmatosed
8 years ago

Indenting can cause a lot of issue just by the spacing fact. Unfortunately it's used because it's an understandable pattern and also means you don't need to have a symbol or graphic to indicate threading. This kind of goes against the theme independence. It's a balancing act a bit.

#8 @boonebgorges
8 years ago

  • Milestone changed from 1.9 to 2.0

#9 @boonebgorges
8 years ago

Is this a duplicate of #2768?

#10 @boonebgorges
8 years ago

  • Milestone 2.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

#11 @DJPaul
5 years ago

  • Component changed from General - UX/UI to Core
Note: See TracTickets for help on using tickets.