Skip to:
Content

Opened 13 months ago

Closed 7 months ago

#4900 closed defect (bug) (invalid)

Theme compat: notices with P2 theme

Reported by: mercime Owned by:
Milestone: Priority: low
Severity: normal Version: 1.7
Component: Theme Keywords:
Cc:

Description

BuddyPress RC 1 - error:

Notice: Trying to get property of non-object in /xxx/xxx/xxx/xxx/wp-includes/capabilities.php on line 1075
Notice: Trying to get property of non-object in /xxx/xxx/xxx/xxx/wp-includes/capabilities.php on line 1076
Notice: Trying to get property of non-object in /xxx/xxx/xxx/xxx/wp-includes/capabilities.php on line 1076
Notice: Trying to get property of non-object in /xxx/xxx/xxx/xxx/wp-includes/capabilities.php on line 1079
Notice: Trying to get property of non-object in /xxx/xxx/xxx/xxx/wp-includes/capabilities.php on line 1079

Attachments (4)

p2-not-compat.jpg (398.0 KB) - added by mercime 13 months ago.
p2-flashing-updates.jpg (100.8 KB) - added by mercime 13 months ago.
flashing updates high number when only made status update
buddypress.php (421 bytes) - added by mercime 13 months ago.
buddypress.php for P2 theme
p2-vertspace-imgavatar.jpg (207.1 KB) - added by mercime 13 months ago.
with buddypress.php long vertical space and image avatar issue

Download all attachments as: .zip

Change History (18)

mercime13 months ago

comment:1 mercime13 months ago

P2 is a special theme which some are already using in BuddyPress sites. Per attached image, following issues show up with theme compat:

  1. Members page title is repeated
  1. Author post area shows up with warning in the background per original post
  1. Action buttons are cut off
  1. Clear left needed for li elements in member list
  1. Avatars in Groups and Members Widget are much smaller compared to the default avatars in other BP widgets
  1. Item meta .activity in Groups and Members Widget area are not aligned under names of Group or Members

<delete>7. Who's Online widget - duplication of mercime avatar after recently posting status update</delete>

Some of the issues above could be addressed

  • #1, #2, #3: special case, providing custom buddypress.php file to be uploaded by user in theme's folder
  • #4, #5, #6: needs patch for bp-legacy's css

<delete>#7: needs patch - the issue shows up in twenty twelve theme as well</delete>

Last edited 13 months ago by mercime (previous) (diff)

comment:2 DJPaul13 months ago

line 1079, wp-includes/capabilities.php - get_post_type_object( 'bp_members' ) === null

caused by current_user_can('edit_posts') at http://themes.trac.wordpress.org/browser/p2/1.4.2/entry.php#L51

comment:3 DJPaul13 months ago

Separate tickets would have been easier to track these issues -- going to keep this one for the Notices, and will a new ticket for all styling, and another for the widget

comment:4 DJPaul13 months ago

For widget avatars and "Item meta .activity", see #4869

Last edited 13 months ago by DJPaul (previous) (diff)

comment:5 DJPaul13 months ago

  • Milestone changed from Awaiting Review to 1.7

comment:6 DJPaul13 months ago

  • Summary changed from P2 theme not compatible with BuddyPress to Theme compat: notices with P2 theme

comment:7 DJPaul13 months ago

Other CSS issues in #4904

comment:8 mercime13 months ago

Separate tickets would have been easier to track these issues -- going to keep this one for the Notices

Thanks. Will point this ticket to P2 users for 1.7 theme compat.

Other issue found:

I'm attaching https://buddypress.trac.wordpress.org/attachment/ticket/4900/buddypress.php file which users can upload to P2 theme folder in server. Fixes #1, #2, and #3. Upload of this file shows some more issues https://buddypress.trac.wordpress.org/attachment/ticket/4900/p2-vertspace-imgavatar.jpg :

  • 9. very long vertical space between status/item header and activity-list/members-list/groups-list,etc.
  • 10. activity item img.avatar is not displayed inline

#9 and #10 could be addressed via CSS fixes specific to the P2 theme's stylesheet as these issues do not show up in other WP themes I tested

#buddypress ul.item-list {
    clear: none !important;
}  
#buddypress .activity-list .activity-content .activity-header img.avatar {
    display: inline;
} 


Last edited 13 months ago by mercime (previous) (diff)

mercime13 months ago

flashing updates high number when only made status update

mercime13 months ago

buddypress.php for P2 theme

mercime13 months ago

with buddypress.php long vertical space and image avatar issue

comment:9 johnjamesjacoby13 months ago

Not extremely concerned with these. P2 is getting more attention internally at Automattic, and we'll see an influx of themes where BuddyPress doesn't work perfectly after 1.7 ships.

comment:10 DJPaul13 months ago

  • Milestone changed from 1.7 to Future Release
  • Priority changed from normal to low
  • Version changed from 1.7-beta to 1.7

comment:11 mercime13 months ago

#7 above is not valid. Tester used my avatar and username plus _one.

comment:12 mercime7 months ago

Just for the record, no one is reporting issues with P2 theme in BP forums nor are there any requesting assistance for theme compat with P2 theme.

comment:13 mercime7 months ago

In that regard, I suggest we close this ticket already. Anyone who has an issue in the future can reopen.

comment:14 boonebgorges7 months ago

  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from new to closed

Sounds good, mercime. Thanks for being on top of this one!

Note: See TracTickets for help on using tickets.