Skip to:
Content

Opened 14 months ago

Last modified 13 months ago

#4820 reopened defect (bug)

Activation Link bug ? (404)

Reported by: grosbouff Owned by:
Milestone: Future Release Priority: normal
Severity: normal Version: 1.7
Component: Core Keywords: reporter-feedback
Cc: grosbouff

Description

Hi, I searched everywhere for this and my conclusion is that this is a BuddyPress bug,
but i'm not 100% sure since WP and BP seems to handle registration differently.

I have a website setup with WP+BP.
The homeurl (http://www.pencil2d.org) and the siteurl (http://www.pencil2d.org/wordpress) are different.
When I try to register with BP installed, I get a mail with an activation link which looks like

http://www.pencil2d.org/wp-activate.php?key=....

and that address returns a 404.

Registration with WP only is fine (but there is no such link in their email)...

Any idea ?

Change History (13)

comment:1 r-a-y14 months ago

  • Keywords needs-testing removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4755.

comment:2 r-a-y14 months ago

Hi grosbouff,

I installed WordPress in a subdirectory and am running BP trunk r6784.

When I click on the "Register" link (/wordpress/wp-login.php?action=register), I get redirected to /register/, which is the correct behavior.

On your site (Pencil2d.org), it doesn't redirect; however, if I manually go to pencil2d.org/register/, I see the registration page.

I have a feeling your issue might be related to #4809. Can you take a look at the patch in that ticket and see if it resolves your problem?

comment:3 grosbouff14 months ago

  • Cc grosbouff added

Hi r-a-y and thanks for you reply.

I did apply your patch (changed the function like this, is this ok ?), but the bug still occurs. (the link in the mail is ....org/register/wp-activate.php?key=..., which returns a 404).
:(
If you want I can give you an access at the administration panel or whatever !

comment:4 grosbouff14 months ago

Hi, after further investigation, I don't think the problem has to deal with bp_core_wpsignup_redirect().
My problem concerns the activation link...
I dug the code a little and found that :
The link is returned in the email by the function bp_get_activation_page().

In bp_get_activation_page(),
bp_has_custom_activation_page() returns false, and that's strange because I have an activation page setup in settings>buddypress>pages.

In bp_has_custom_activation_page(),
bp_get_activate_slug returns true BUT bp_locate_template( array( 'registration/activate.php', 'members/activate.php', 'activate.php' ), false ) returns false.

I think the problem is there.
In the 3 theme stacks (my parent theme - my child theme - the bp-legacy theme); there are no

  • registration/active.php
  • activate.php

templates, BUT there is a members/activate.php file under the folder buddypress of the bp-legacy theme.
Seems come bp_locate_template checks for files inside /bp-templates/bp-legacy/ and not /bp-templates/bp-legacy/buddypress/ ? Is it normal ?

comment:5 grosbouff14 months ago

PS : just to let u know : I put set a redirection (regex) on my website to "fix" the bug, but it still occurs without it ! Let me know if you want me to test things.

comment:6 r-a-y14 months ago

  • Keywords reporter-feedback added
  • Milestone set to Awaiting Review

Hi grosbouff,

Thanks for the additional details.

I have a feeling this problem is occurring for child themes. Can you quickly switch to the parent Twenty Twelve theme and see if your email problems are still happening?

Thanks!

comment:7 r-a-y14 months ago

Okay, I just tested a child theme of 2012 and I was able to register successfully and get the activation email.

What revision of trunk are you on?

Feel free to pass your credentials of your site to me:
http://www.google.com/recaptcha/mailhide/d?k=01N5m-sdXQ8d1eLv0_W-2a3w==&c=vVfMbs4ubMYHQ9oUxXueig==

Last edited 14 months ago by r-a-y (previous) (diff)

comment:8 grosbouff14 months ago

Hi r-a-y, that seems right ; with the parent theme (Twenty Twelve) enabled, the email link is ok.
I don't know which revision of BP I have but I last updated from trunk 24 hours ago. I hope it will help !
By the way; the work all of you did on 1.7 is incredible!!
This is very, very good. I'm following BuddyPress since the starts, and this is the first time I see it like... like what I imagine it would be some years ago ! The community only needed time to see that happen !
Good luck.

comment:9 r-a-y14 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted

Hi grosbouff,

I just did a test registration on Pencil2d.org and I can confirm that:

  • I get redirected from /wp-login.php?action=register to /register/
  • My activation email uses the /activate/ slug and not /wp-activate.php

So, it looks like we're good! :)

Did you update to latest trunk?
Are you using multisite? And you did not have the TwentyTwelve theme enabled on the blog?


Thanks for the feedback about 1.7! I remember that you've been using BuddyPress since near the beginning. Glad that you're still using it!

Last edited 14 months ago by r-a-y (previous) (diff)

comment:10 grosbouff14 months ago

r-a-y : be careful :

  • It is my child theme currently enabled (it's a simple child theme derivated twenty twelve)
  • The redirection from /wp-login.php?action=register to /register/ indeed works
  • The redirection from /wp-activate.php to /activate/ works only because I made a custom redirection with a redirection plugin. It DOES NOT WORK without it.

I did recheck the /activate/ link without the redirection (and with the parent theme enabled), it still do not work. Sorry for what I told you yesterday !

I am not multisite but I did a test some times ago. Anyway, I "cleaned" it (no more multisite in the wp-config.php, and I deleted the extra tables)

Strange bug, eh ? Also, have a look at my post #4. I think this might be a good start. Should I reopen this ticket ?

comment:11 r-a-y14 months ago

  • Keywords reporter-feedback added
  • Milestone set to Awaiting Review
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Hi grosbouff,

I can't duplicate your problem on my local testing environment. Like you, I am using a barebones child theme of Twenty Twelve and my activation link uses /activate/. bp_has_custom_activation_page() also returns true for me.

Can you try deleting your 'buddypress' directory and using the latest trunk?

Can you also try a fresh install on a local environment? Try a single site and multisite install and let me know if you are still encountering this issue.

If you'd like, can you pass me an admin login and some FTP credentials to your site? Use the link over here.

comment:12 r-a-y13 months ago

Hi grosbouff,

Any updates here? Have you tried latest trunk?

Please let us know before we close this ticket.

comment:13 DJPaul13 months ago

  • Milestone changed from Awaiting Review to Future Release
Note: See TracTickets for help on using tickets.