Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 3 years ago

#4819 closed enhancement (maybelater)

Save Settings in Components tab on subsite on multisite redirect to main site

Reported by: grapplerulrich Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.7
Component: Core Keywords: needs-patch, trac-tidy-2018
Cc:

Description

I tested out BuddyPress 1.7 today. I think it was version 6779.

I ran it on a subsite on my multisite.

When I saved the settings on the component tab I got directed to:
http://www.example.com/wp-admin/admin.php?page=bp-components&updated=true
instead of:
http://buddypress.example.com/wp-admin/admin.php?page=bp-components&updated=true

Change History (7)

#1 @boonebgorges
8 years ago

  • Milestone changed from Awaiting Review to 1.7
  • Severity changed from major to minor

Moving to 1.7 for review. It's likely that we're building the redirect URL incorrectly.

#2 @grapplerulrich
8 years ago

I was able to solve this by adding

<?php
define ( 'BP_ROOT_BLOG', 25 );

to wp-content/plugins/bp-custom.php.

This shouldn't be something that users has to do. Should I open a new ticket or edit this one?

#3 @boonebgorges
8 years ago

  • Milestone 1.7 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks for investigating.

This is by design. For the moment, you have to define BP_ROOT_BLOG manually. See http://codex.buddypress.org/user/install-buddypress-on-a-secondary-blog/

This is a legacy of the fact that BuddyPress was once necessarily a networkwide plugin. It's a good enhancement idea to get rid of this. Please feel free to open an enhancement ticket with the suggestion that BP_ROOT_BLOG be defined automatically.

#4 @johnjamesjacoby
8 years ago

  • Keywords needs-patch added
  • Milestone set to 1.8
  • Resolution invalid deleted
  • Severity changed from minor to normal
  • Status changed from closed to reopened
  • Type changed from defect (bug) to enhancement

In the meanwhile, you can set 'BP_ENABLE_MULTIBLOG' in bp-custom.php to make it behave the way you intend for it to.

Fixing this would involve a bit of restructuring the way BP_ROOT_BLOG is set in BuddyPress->constants(), to check if BuddyPress is network activated, and spoof the root blog to the current blog if not. Too late in 1.7 to play with this, but it's the last piece of this puzzle.

Reopening, and moving to 1.8 milestone.

#5 @boonebgorges
8 years ago

  • Milestone changed from 1.8 to Future Release

#6 @DJPaul
3 years ago

  • Keywords trac-tidy-2018 added

We're closing this ticket because it has not received any contribution or comments for at least two years. We have decided that it is better to close tickets that are good ideas, which have not gotten (or are unlikely to get) contributions, rather than keep things open indefinitely. This will help us share a more realistic roadmap for BuddyPress with you.

Everyone very much appreciates the time and effort that you spent sharing your idea with us. On behalf of the entire BuddyPress team, thank you.

If you feel strongly that this enhancement should still be added to BuddyPress, and you are able to contribute effort towards it, we encourage you to re-open the ticket, or start a discussion about it in our Slack channel. Please consider that time has proven that good ideas without contributions do not get built.

For more information, see https://bpdevel.wordpress.com/2018/01/21/our-awaiting-contributions-milestone-contains/
or find us on Slack, in the #buddypress channel: https://make.wordpress.org/chat/

#7 @DJPaul
3 years ago

  • Milestone Awaiting Contributions deleted
  • Resolution set to maybelater
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.