Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

#4521 closed defect (bug) (fixed)

Buddypress installation wizard could not finish due to strict security setting on webhost

Reported by: harmr's profile harmr Owned by:
Milestone: Priority: normal
Severity: major Version:
Component: Core Keywords: reporter-feedback
Cc:

Description

I tried to instally buddypress on my wordpress site which is hosted by twosteps.net.
Activating the plugin worked, but when I started the installation wizard and arrived at step 3 - Permalinks - I got the following error:

Warning: phpinfo() has been disabled for security reasons in /home/htdocs/wp-includes/functions.php on line 2848

I could not get beyond this point and thus couldnt finish buddypress installation. My provider has a special focus on security and thus disabled access to phpinfo. Buddypress should not only check if phpinfo is available but also if it can be accessed.

Change History (3)

#1 @DJPaul
11 years ago

BuddyPress doesn't use phpinfo() anywhere. I've just checked.

#2 @DJPaul
11 years ago

  • Keywords reporter-feedback added

harmr, can you scan inside your plugins and themes folder to see what you can find that uses phpinfo()?

#3 @johnjamesjacoby
11 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to fixed
  • Status changed from new to closed

Wizard is gone 1.7. Closing as fixed.

Note: See TracTickets for help on using tickets.