Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4520 closed enhancement (duplicate)

lacking nested/conditional profile fields in the Core

Reported by: redrocktoday's profile redrocktoday Owned by:
Milestone: Priority: normal
Severity: major Version: 1.2
Component: Extended Profile Keywords:
Cc:

Description

I need conditional profile fields to be added to the default BuddyPress template: a drop-down select boxes, depending on what is selected, a second dropdown select boxes should appear to let user select, then depending on what is selected for the second, a third dropdown select boxes should appear, and in total, I need four layers of these conditional profile fields.

For example, the first drop-down could be states(Arizona, California, Texas etc.), then depend on what user selects, the second dropdown displays the towns in that selected state, so if the user selected ‘California’ in first dropdown, a set of towns in California will be available in the option list for the second dropdown; if the user selected ‘Texas’ in first dropdown, a set of towns in Texas will be available in the option list for the second drop down, and so forth…

These nested/conditional profile fields will have many applications for creating larger websites, not just location related sites...

It would be great if next release of BuddyPress could come with this nested profile fields, and in addition, a functionality that allow admins to create initial groups based on certain user profile fields -which seems very nature. And as a social networking platform, these functionalities should come from the core of software, not from Plugins - as many group related plugins will be depending on these functionalities to make themselves sophisticated enough to make user experience more fullfilled.

Change History (2)

#1 @r-a-y
11 years ago

  • Component changed from Core to XProfile
  • Resolution set to duplicate
  • Status changed from new to closed
  • Type changed from defect (bug) to enhancement
  • Version set to 1.2

Duplicate of #579.

Next release will not include conditional profile fields as the majority of the focus is on universal theme compatibility.

If a plugin exists out there that is nicely coded, please list it and we might consider merging it into core in a future release.

#2 @DJPaul
11 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.