Skip to:
Content

Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#3684 closed defect (bug) (fixed)

New blog creation in default theme – Blog URL suffix text incorrect for subdomain installation in case of domains without www

Reported by: zbacsi Owned by:
Milestone: 1.5.2 Priority: normal
Severity: normal Version:
Component: Blogs Keywords: reporter-feedback
Cc:

Description

Wordpress 3.2.1, BuddyPress 1.5

This bug is NOT the same as #3103

If the root blog is mydomain.com (without www) the suffix text should end in:

http://[form input].mydomain.com

Instead what appears is:
http://[form input].http://mydomain.com

I realized the regexp is wrong in this file: http://buddypress.trac.wordpress.org/browser/trunk/bp-themes/bp-default/registration/register.php#L193

The current regexp is:

preg_replace( '|^https?://(?:www\.)|', '', "http://www.mysite.com");
mysite.com

preg_replace( '|^https?://(?:www\.)|', '', "http://mysite.com");
http://mysite.com

Recommended regexp:

preg_replace( '|^https?://(www\.)*|', '', "http://www.mysite.com");
mysite.com

preg_replace( '|^https?://(www\.)*|', '', "http://mysite.com");
mysite.com

Change History (4)

comment:1 boonebgorges2 years ago

  • Keywords reporter-feedback added

I can't reproduce this on my subdomain installations, which are not using www in their domain names.

I have a local installation http://subdomain.test, and the text on subdomain.test/blogs/create reads:
Site Domain: [form input].subdomain.test/

Can you give the exact steps necessary to reproduce the issue?

comment:2 boonebgorges2 years ago

  • Milestone changed from Awaiting Review to 1.5.2

See also #3760

comment:3 boonebgorges2 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5380]) Introduces bp_blogs_get_subdomain_base(). Fixes subdomain address base on registration screen. Fixes #3684

comment:4 boonebgorges2 years ago

(In [5381]) Introduces bp_blogs_get_subdomain_base(). Fixes subdomain address base on registration screen. Fixes #3684

Note: See TracTickets for help on using tickets.