Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#3290 closed defect (bug) (fixed)

"accepted your friendship request" notification does not disappear when clicked.

Reported by: lightcapturer Owned by:
Milestone: 1.5 Priority: normal
Severity: Version: 1.5
Component: Messages Keywords:
Cc: contact@…

Description

But it disappear when the second notification came and clicked.

Attachments (1)

notifications.jpg (83.0 KB) - added by lightcapturer 10 years ago.

Download all attachments as: .zip

Change History (10)

#1 follow-up: @lightcapturer
10 years ago

The next problem:

Notification only say "one" even though there are two notifications in them.

#2 @luccame
10 years ago

I was able to replicate this on trunk.

When you have a single friendship request accepted, the link in notifications points to:
http://www.example.com/members/user-who-accepted/?new
but clicking the link does not clear the notification

When you have multiple friendship request accepted, the link in notifications points to:
http://www.example.com/members/yourself/friends/my-friends/newest
and clicking this link clears the notification

#3 in reply to: ↑ 1 @luccame
10 years ago

Replying to lightcapturer:

The next problem:

Notification only say "one" even though there are two notifications in them.

.
I think this is the intended behaviour since both notifications are related to the same component.

#4 @Dennissmolek
10 years ago

  • Cc contact@… added
  • Keywords needs-ui added

I think that it should say two. In facebook for example it lists both as separate events to be notified about.

So the issues here are the number not representing the actual events, and a single friendship request does not clear the notification.

#5 @DJPaul
10 years ago

Existing ticket #3008 covers the number discrepancy, but that is not a regression and is currently working as designed. It won't be addressed in 1.3. This ticket can focus on the single friendship requests not clearing.

#6 @DJPaul
10 years ago

  • Keywords needs-ui removed
  • Milestone changed from Awaiting Review to 1.3

confirmed in trunk

#7 @DJPaul
10 years ago

Looking at branch, I can't see why the links are different. user-who-accepted/?new doesn't appear to do anything. Tempted to patch this so they both go to /friends/my-friends/newest?

#8 @boonebgorges
10 years ago

Looking at branch, I can't see why the links are different. user-who-accepted/?new doesn't appear to do anything. Tempted to patch this so they both go to /friends/my-friends/newest?

Agreed.

#9 @djpaul
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4551]) Change single friendship notification URL to clear the notification. Fixes #3290

Note: See TracTickets for help on using tickets.