Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#3289 closed defect (bug) (fixed)

BP can not access the pages when activated on the sub-blog

Reported by: lightcapturer Owned by:
Milestone: 1.5 Priority: normal
Severity: normal Version: 1.5
Component: Core Keywords: needs-testing
Cc:

Description

Recently I tried to activate BuddyPress that I downloaded from svn, and I activate it on the sub-blog. Apparently it can not access the pages on the sub-blog.

Maybe would be better to adding the options in the admin panel, on which blog the BuddyPress will be activated, without touching the wp-config.php.

Change History (11)

#1 @DJPaul
10 years ago

Are you referring to the BP_ROOT_BLOG setting?

#2 @lightcapturer
10 years ago

Yes I am.

#3 @DJPaul
10 years ago

  • Keywords needs-testing added

Is someone able to test BP_ROOT_BLOG on trunk/1.3?

#4 follow-up: @boonebgorges
10 years ago

I've tested it pretty extensively. But it would help if someone else did so as well.

FWIW I'm not 100% sure I understand what the OP means by "accessing the pages on the sub-blog".

#5 @johnjamesjacoby
10 years ago

  • Severity set to normal

A setting like this would be helpful in Multiblog too. Thinking it's too advanced a setting for the majority?

#6 @johnjamesjacoby
10 years ago

  • Component changed from Skeleton Component to Core

#7 @lightcapturer
10 years ago

I just want to test the BP 1.3/trunk but found an error when activating. I've reported the error here http://buddypress.trac.wordpress.org/ticket/3369.

#8 in reply to: ↑ 4 ; follow-up: @lightcapturer
10 years ago

Replying to boonebgorges:

FWIW I'm not 100% sure I understand what the OP means by "accessing the pages on the sub-blog".

The pages that I mean is that will be used as slugs. When BuddyPress enabled on sub-blogs using BP_ROOT_BLOG setting in wp-config, the pages on the sub-blog do not appear on the BuddyPress Settings.

#9 in reply to: ↑ 8 @lightcapturer
10 years ago

Replying to lightcapturer:

Replying to boonebgorges:

FWIW I'm not 100% sure I understand what the OP means by "accessing the pages on the sub-blog".

The pages that I mean is that will be used as slugs. When BuddyPress enabled on sub-blog (on WP Multisite) using BP_ROOT_BLOG setting in the wp-config.php, the pages on the sub-blog do not appear on the BuddyPress Settings.

#10 @boonebgorges
10 years ago

  • Milestone changed from Awaiting Review to 1.3

OK, I get it now. Thanks for the further explanation.

#11 @boonebgorges
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4796]) On Pages dashboard panel, switch to BP_ROOT_BLOG if it's set to something other than the current blog. Fixes #3289

Note: See TracTickets for help on using tickets.