Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#3222 closed defect (bug) (fixed)

Xprofile - alignment and shades

Reported by: ezd's profile ezd Owned by:
Milestone: 1.5 Priority: normal
Severity: normal Version:
Component: Extended Profile Keywords: commit
Cc:

Description

Please see the attached screenshot for details.

  • The alignment is broken on IE (don't know about other browsers)
  • Some background shades are missing

Attachments (2)

xprofile.jpg (117.9 KB) - added by ezd 13 years ago.
3222.diff (548 bytes) - added by boonebgorges 13 years ago.

Download all attachments as: .zip

Change History (16)

@ezd
13 years ago

#1 @DJPaul
13 years ago

What version IE did you test on? IE9 seems fine.

#2 @DJPaul
13 years ago

  • Keywords reporter-feedback added

#3 @ezd
13 years ago

  • Keywords reporter-feedback removed

Safari 5. Sorry, haven't tested other browsers.

#4 @DJPaul
13 years ago

Safari 5 on Mac works fine for me, too. Per your screenshot, your xprofile table looks to be twice as tall as mine is. I'm not sure how a clean install here is different from a clean install on your end.

#5 @DJPaul
13 years ago

  • Keywords reporter-feedback added

Can you recreate this on the current trunk or on testbp?

#6 @johnjamesjacoby
13 years ago

  • Milestone changed from Awaiting Review to 1.3
  • Severity set to normal
  • Version 1.3 deleted

I can see where it's wrong. Moving to 1.3.

#7 @johnjamesjacoby
13 years ago

  • Keywords needs-patch ui-feedback added; reporter-feedback removed

#8 @DJPaul
13 years ago

Any clues? :)

#9 @boonebgorges
13 years ago

  • Keywords has-patch dev-feedback added; needs-patch removed

The problem is that we do a global reset of p margin-bottom, and follow it up with p:last-child margin-bottom: 0. IE8 does not understand :last-child.

However, IE8 does support :first-child. 3222.diff reorganizes paragraph margins in such a way that it uses :first-child, but should have the same net effect.

@boonebgorges
13 years ago

#10 @DJPaul
13 years ago

  • Keywords commit added; ui-feedback has-patch dev-feedback removed

I think this is ok to do for these tags, because they pretty much break the layout of the page. Remember to do the same in editor-style.css.
FWIW, I don't think it's a good idea for us to go through and replace any of the other :last-child selectors because we'll likely break the design. I think we should, if we find any other IE8 :last-child issues while in beta, look at those on a case-by-case.

#11 @boonebgorges
13 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4807]) Fixes alignment of xprofile data in IE and other browsers that don't recognize :last-child. Just kidding, there are no other browsers that don't recognize :last-childe. Fixes #3222

#12 @boonebgorges
13 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Apparently the changes in r4807 are messing other stuff up, so these styles should be made more specific.

#13 @boonebgorges
13 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4852]) Reverts changes in r4807 and makes last-child padding more specific to profile fields. Fixes #3222

#14 @boonebgorges
13 years ago

(In [4853]) Reverts r4807 for editor stylesheet. See #3222

Note: See TracTickets for help on using tickets.