Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 10 years ago

#1532 closed defect (bug) (wontfix)

Editing username in DB breaks profile pages.

Reported by: markmcwilliams Owned by:
Milestone: 1.5 Priority: minor
Severity: Version:
Component: Core Keywords:
Cc: Peter, Anselmo, sbrajesh

Description

I'm new to BuddyPress, but I did a little searching around and couldn't find anyone else report this issue, and I am trying out the latest trunk on a single WordPress install instead of MU! (GREAT work BTW Andy, nice to see it functioning like this!)

Basically, when I visit http://www.siteurl.com/members/admin-here/ it'll take me straight back to the homepage (http://www.siteurl.com/) and it's not just that either, it's ANYTHING related to my profile that'll make it happen? - I have been around BuddyPress.org and it doesn't happen for me there, but then I'm not an admin!

Can anyone actually confirm if this is indeed a bug, or I have maybe done something wrong somewhere, but I don't think so anyways? I have left the setup just as it would normally be, after activation of the plugin, but who knows? ... Thanks! :)

Change History (26)

#1 @andrea_r
11 years ago

The profiles and other areas are shown as long as you have a buddypress theme enabled on the blog. Did you do that? :)

#2 @markmcwilliams
11 years ago

Yup, I do have the BuddyPress Theme enabled on the blog! :)

#3 @markmcwilliams
11 years ago

To add, I even went as far as adding a new member and see if their profile worked as it should, which it did! :) That's the good bit! - But it still means somethings wrong somewhere, that stops me, being the admin user, use the front-end profile side of things?

Can ANYONE else confirm seeing this themselves too?

#4 @apeatling
11 years ago

Do other pages work? Have you set permalinks to something other than default?

#5 @markmcwilliams
11 years ago

If you mean other pages like Activity, Members and Groups, then YES they do work as I believe they should! Permalinks haven't been altered at all for BuddyPress, and it's just setup as /2010/01/sample-post/ on the site if that helps?

Me being the admin, can view a normal members profile OK, just like they could themselves, but whenever ANYONE attempts to view my page, it just redirects to the homepage which shouldnt be happening! - Something is broken somewhere! :(

#6 @Peter Anselmo
11 years ago

  • Cc Peter Anselmo added

It may or may not be the same bug, but I am unable to view my profile on buddypress.org. Same thing - it just redirects to the homepage.

However, I hypothesize it's because I have a space in my username. I haven't had a chance to test this but it seems like a likely candidate.

#7 @markmcwilliams
11 years ago

You could be onto something Peter, and in which case it's a problem that'll need to be fixed INHO, although I'm surprised nobody has run into this issue before and not reported it? - Does everyone run without a space in their username, or something? ;)

#8 @DJPaul
11 years ago

Space in the username is the key to this. Try putting this in your wp-config.php file:

define( 'BP_ENABLE_USERNAME_COMPATIBILITY_MODE', true );

#9 @markmcwilliams
11 years ago

Well adding that to my wp-config.php file does solve the problem, however it shouldn't have been a problem in the first place, and to be really honest, I actually want the hyphen appearing! - Which asks the question, will something be done to sort the problem so people don't need to add that? =/

#10 @apeatling
11 years ago

I can't reproduce this at all, all users I try with dashes in the username work fine.

#11 @markmcwilliams
11 years ago

Well I guess that'll be it, but it doesn't work for me, I know that for a fact and it's a shame you can't reproduce! - Would it make a difference that my login username is say username but the URL slug has been altered in phpMyAdmin for example and shows as user-name or not? - It's about the only other thing I can think of right now, cause that's what is happening here!

#12 @apeatling
11 years ago

If you changed your username in phpMyAdmin that will probably break it.

#13 follow-up: @markmcwilliams
11 years ago

So it'll work in WordPress, but when it comes to BuddyPress, if anything has been changed in phpMyAdmin then it'll break? Is there... 1) A way to fix that problem? 2) If it's not fixable, something added to either the Codex, or just the BuddyPress.org site to make other users aware? - Fingers crossed it can be fixed! ;)

#14 in reply to: ↑ 13 ; follow-up: @sbrajesh
11 years ago

  • Cc sbrajesh added

Replying to markmcwilliams:

So it'll work in WordPress, but when it comes to BuddyPress, if anything has been changed in phpMyAdmin then it'll break? Is there... 1) A way to fix that problem? 2) If it's not fixable, something added to either the Codex, or just the BuddyPress.org site to make other users aware? - Fingers crossed it can be fixed! ;)

No It is not the problem with buddypress only. If you change your user name to something else in PhpMyAdmin and have permalinks enabled, even author archive page will not work for admin. I have faced this on one of my wp blogs. Does the author archive for the renamed admin is working for you ?

#15 @apeatling
11 years ago

  • Priority changed from major to minor

#16 @apeatling
11 years ago

  • Summary changed from Admin Not Able To View Own Profile? to Editing username in DB breaks profile pages.

#17 in reply to: ↑ 14 @markmcwilliams
11 years ago

Replying to sbrajesh:

No It is not the problem with buddypress only. If you change your user name to something else in PhpMyAdmin and have permalinks enabled, even author archive page will not work for admin. I have faced this on one of my wp blogs. Does the author archive for the renamed admin is working for you ?

Without BuddyPress activated, although I have edited (not quite the username) but the way the user has their author page URL show, as in /mark-mcwilliams/, it works fine on my WordPress install. Activate BuddyPress though, and bang, it's broken and won't show unless you enter that code in your wp-config.php file which then shows your profile page as being /markmcwilliams/ which I'm not exactly after!

#18 @apeatling
11 years ago

  • Milestone changed from 1.2 to 1.2.1

Bumping this to 1.2.1 since it is outside the scope of normal function.

#19 follow-up: @mrmaz
10 years ago

  • Component set to Core

I'm not sure that its a good idea to support direct editing of data in the DB? That is a bit like opening pandora's box.

I vote this should be resolved as wontfix unless there is some deeper issue that I am not seeing.

#20 in reply to: ↑ 19 @sbrajesh
10 years ago

Replying to mrmaz:

I'm not sure that its a good idea to support direct editing of data in the DB? That is a bit like opening pandora's box.

I vote this should be resolved as wontfix unless there is some deeper issue that I am not seeing.

When we talk about securing wordpress, it is advised to change the username from admin to something else. Wordpress below 3.0 does not allows this directly,so DB edit is required(or there is a plugin, I don't remember the name, is required); yes, in wp 3.0(in trunk version), admin username can be chosen at the time of setup, so this may not be a thing to look after wp 3.0 is out.

#21 follow-up: @DJPaul
10 years ago

What exactly are you changing the user_login field to? If it contains a dot or some other symbols, that's when you need to put on BP_ENABLE_USERNAME_COMPATIBILITY_MODE.

On my 1.2.3 dev install, I've just manually changed user_login of "admin" to "admin2" and everything worked fine.

#22 @johnjamesjacoby
10 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

#23 in reply to: ↑ 21 @markmcwilliams
10 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to DJPaul:

On my 1.2.3 dev install, I've just manually changed user_login of "admin" to "admin2" and everything worked fine.

I don't care what the user login happens to be, I'm on about that part that people can visit their account/profile/author bit, as in like the example back up at the start! Actually having the hyphen in the URL, not like adding that bit of code which removes the hyphen and makes everything work, I know it does ... that's not what I have been getting at!

#24 follow-up: @DJPaul
10 years ago

Exactly which field are you editing in the DB please; what's the column name?

#25 in reply to: ↑ 24 @markmcwilliams
10 years ago

Replying to DJPaul:

Exactly which field are you editing in the DB please; what's the column name?

That'd be the user_nicename field in the *_users table!

#26 @boonebgorges
10 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

I'm unable to reproduce the exact problem described by markmcwilliams on the latest trunk. When I manually change the user_nicename of a user (from say boone5 to boone-5) I am able to visit the user's profile at members/boone-5 without a problem. A few other things break; eg activity @-mentions, which are detected with username_exists().

Given that:

  • The problem as stated doesn't exist on the latest trunk
  • As sbrajesh says, changing the admin username is no longer needed because of WP 3.x (though of course it never really was needed, since you could always make a new admin user and demote the original one)
  • Some of the OP's concern's might be addressed by #1978, to which extent this is a duplicate
  • And, perhaps most importantly, as apeatling and mrmaz have suggested, changing a user_nicename manually is, at best, an edge case, and probably something that we don't want to encourage in the core of BP;

I'm closing this ticket.

It's possible that one could extract a reasonable enhancement request from this discussion - a non-intrusive, safe way to change a username throughout a BP installation (something I've had to do before, which requires a number of careful queries to change all instances). But it seems outside the scope of this bug report.

Note: See TracTickets for help on using tickets.