Skip to:
Content

BuddyPress.org

Opened 3 months ago

Closed 2 weeks ago

#8495 closed defect (bug) (worksforme)

Search form not shown when using Storefront theme from WooCommerce

Reported by: rsalafy Owned by:
Milestone: Priority: normal
Severity: normal Version: 8.0.0
Component: Core Keywords: dev-feedback
Cc:

Description

Search form not shown when using Storefront theme from WooCommerce

Change History (11)

#1 @imath
3 months ago

  • Keywords reporter-feedback added

Hi,

Could you be more specific? What search form are you talking about: Activity, Members..., all?

#2 @rsalafy
3 months ago

All search related to BuddyPress like BuddyX theme have.

Does Buddypress have built-in search function/widget?

Does search form in BuddyX their own feature?

#3 @rsalafy
3 months ago

There is no search form for BuddyPress-related things when using Twenty Twenty One theme neither.

#4 @rsalafy
3 months ago

I'm currently using BuddyPress Global Search plugin (https://wordpress.org/plugins/buddypress-global-search/).

But its last update date is 2 years ago. And I want to use BuddyPress's own search form/function/widget if possible.

#5 @imath
3 months ago

  • Keywords dev-feedback added; reporter-feedback removed

@vapvarun could you have a look at it? I can't manage to reproduce with TwentyNineteen.

#6 @rsalafy
3 months ago

The problem seems related to Template Pack.

Note: BuddyX requires to switch to BuddyPress Nouveau or user can't use its theme.

#7 @rsalafy
3 months ago

Another thing, seems like the search form glued together with the update status form, because it won't shown to non-logged in users.

I need the non-logged users be able to do search for BuddyPress. Maybe in form of a widget.

WordPress's default search form don't search on BuddyPress.

#8 @rsalafy
3 months ago

I think I've solved this problem with switched the template pack from BuddyPress Legacy to BuddyPress Nouveau.

#9 @rsalafy
3 months ago

I think the search form for BuddyPress for non-logged users is also existed.

I'm using Android's Opera browser before, and the form won't show up. Even after I refreshed it multiple times. Even after I switched to Incognito mode.

But when I'm using Android's Firefox browser (and not logged in) the search form for BuddyPress appears.

#10 @wbcomdesigns
3 months ago

Storefront with Legacy template
Sitewide Activity does not search form like group and member directory have.
Logout: https://prnt.sc/17oxvi4
Login: https://prnt.sc/17oy0cz

@rsalafy

But it's not a theme-specific issue
Activity search is already part of BuddyPress Nouveau
https://nimbus-screenshots.s3.amazonaws.com/s/70cea14bf71f7d1d416100636967a105.png

#11 @imath
2 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.