Skip to:
Content

BuddyPress.org

Opened 5 years ago

Closed 10 months ago

#8068 closed enhancement (fixed)

Site creation confirmation markup should be customizable

Reported by: boonebgorges's profile boonebgorges Owned by: imath's profile imath
Milestone: 12.0.0 Priority: normal
Severity: normal Version:
Component: Blogs Keywords: has-patch
Cc:

Description

When you create a site, the confirmation message comes from bp_blogs_confirm_blog_signup(). It's hardcoded in such a way that it can't be easily modified. The only way is to supply your own version, which in turn can only be done by replacing the handful of functions in front of it: bp_blogs_validate_blog_signup() and bp_show_blog_signup_form(), the latter of which is called from the blogs/create.php template. That's a lot of logic to have to reproduce just to replace a bit of markup.

The best ("best") solution is probably to move the confirmation logic to a template - say, blogs/confirm.php. If we feel like that's too much of a change, we could probably get away with the creative use of some short-circuit filters.

Change History (3)

#1 @imath
17 months ago

  • Milestone changed from Up Next to 12.0.0

This ticket was mentioned in PR #142 on buddypress/buddypress by @imath.


10 months ago
#2

  • Keywords has-patch added; needs-patch removed

The fact it's possible since BP 7.0 to pass arguments to a template (see #8350) made the fix a lot more easier!

Trac ticket: https://buddypress.trac.wordpress.org/ticket/8068

#3 @imath
10 months ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 13530:

Blogs: move site creation confirmation markup into BP Template Packs

To make the site creation confirmation markup generated by the bp_blogs_confirm_blog_signup() function easily customizable, we've moved it inside a new template of our BP Template Packs:

  • src/bp-templates/bp-legacy/buddypress/blogs/confirm.php
  • src/bp-templates/bp-nouveau/buddypress/blogs/confirm.php

Props boonebgorges, dcavins

Fixes #8068
Closes https://github.com/buddypress/buddypress/pull/142

Note: See TracTickets for help on using tickets.