Skip to:
Content

BuddyPress.org

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#8050 closed defect (bug) (fixed)

Members directory 'Order By' options not working

Reported by: dontdream Owned by: boonebgorges
Milestone: 4.2.0 Priority: normal
Severity: normal Version: 4.0.0
Component: Templates Keywords:
Cc:

Description

When

  1. using the Legacy template pack, and
  2. the current user is logged out

the Members directory 'Order By' options are no longer working. The AJAX call completes, but the members remain always ordered by 'Last Active'.

This has something to do with the 'bp-members-filters' cookie not being set, but I've been unable to dig further, or to find out when the bug was first introduced.

Change History (4)

#1 @dontdream
8 months ago

Sorry, the cookie name is 'bp-members-filter', not 'bp-members-filters'.

#2 @boonebgorges
8 months ago

  • Milestone changed from Awaiting Review to 4.2.0
  • Version changed from 4.1.0 to 4.0.0

Thanks for the report, @dontdream. I've confirmed the bug. It looks like the member/groups directory were missed when cookie preferences were removed from Legacy directories in [12257]. See #7856.

#3 @boonebgorges
8 months ago

  • Owner set to boonebgorges
  • Resolution set to fixed
  • Status changed from new to closed

In 12334:

BP-Legacy: Ensure that member/group directory sort works for non-logged-in users.

[12257] removed cookie-based sorting for the activity directory, but the change
was not properly ported to other directory types.

Fixes #8050.

#4 @boonebgorges
8 months ago

In 12335:

BP-Legacy: Ensure that member/group directory sort works for non-logged-in users.

[12257] removed cookie-based sorting for the activity directory, but the change
was not properly ported to other directory types.

Merges [12334] to the 4.0 branch.

Fixes #8050.

Note: See TracTickets for help on using tickets.