Skip to:
Content

BuddyPress.org

#7945 closed defect (bug) (wontfix)

Change buddypress permalinks wont work for activity stream

Reported by: der_velli Owned by:
Milestone: Priority: high
Severity: normal Version:
Component: Friends Keywords:
Cc:

Description

Hi

i want to change “friends” in “contacts” even for the domain – like in the “friendship” request emails:

domain.com/buddypress/all-members/friends/requests/
change to
domain.com/buddypress/all-members/contacts/requests/

On BuddyDev i get a hack for this:

define( 'BP_FRIENDS_SLUG', 'contacts' );

in the bp-custom.php will makes fine contact permalinks.
https://buddydev.com/support/forums/topic/change-buddypress-permalinks/#post-16778

BUT the activity stream filtered by “friends” (now contacts) won’t work. i get a 404.

domain.com/buddypress/all-members/membername/activity/friends/
now
domain.com/buddypress/all-members/membername/activity/contacts/

Brajesh from BuddyDev thinks its a BP Bug. Any suggestions or ideas?

Cheers

WP 4.9.8 / BP 3.1.0 / PaidMembership Pro 1.9.5.3 / Theme Kleo 4.3.10

Change History (1)

#1 @DJPaul
14 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Activity stream links are hardcoded. It's not a bug, but a reflection of a legacy design decision. You'll have to do a search-replace in the database directly. wp search-replace might help with that.

Note: See TracTickets for help on using tickets.