Skip to:
Content

Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#7453 closed defect (bug) (wontfix)

CSS conflict with Canvas theme

Reported by: wonderdog4 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8.0
Component: (not sure) Keywords:
Cc:

Description

I am using BuddyPress 2.8.1.

I am reporting this in case somebody wants to resolve it in a future release. I have been having issues with this for three years. In the past 24 hours, one of the Woocommerce Ninjas was able to help me resolve it. This is her explanation of the problem"

"The BuddyPress plugin styles are written in such a way that they override most of the styling added through Canvas [theme] - but not all of it."

THE PROBLEM
When using BuddyPress with the Woocommerce Canvas theme, the buttons on the BuddyPress auto-generated pages (members, activity, etc) disappear into the background and become invisible to users.

THE WORKAROUND
In order to resolve this, additional CSS has to be added to the theme's custom css element.

I'm not a programmer. I don't know if this is a bug or not. I am just a user who has been struggling with this issue for three years and am happy to have it resolved. I am reporting it out of appreciation to the person who helped me resolve it.

Change History (4)

#1 @hnla
11 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

@wonderdog4 thanks for raising the issue and sorry that you've had a problem with this for so long.

Unfortunately it's very hard if not impossible for BP ( or any other plugin) to write styles - in a theme agnostic manner - that would suit potentially any theme where styles/layout are unknown, we can only do so much sadly.

Attempting to 'fix' styling issues for any potential theme is not really practical and really the fixes have to come from the theme end where it knows exactly what the issue is.

In reality this sounds as though this themes styles overpower ours and we have since 1.7 used a quasi namespace approach to styling our elements as all being nested in a #buddypress id element which lends a fair bit of weight and specificity.

For the moment fixing this from the BP end is unlikely to be practical due to potential issues we might bring to other themes and our styles must be non theme specific so this ticket should be marked as a 'wontfix' for the moment but please do leave a link to your site and an affected page and if time we can look and see if there is a long term solution that could be effected.

#2 @wonderdog4
11 months ago

NO worries. I put it in a child theme.

#3 @hnla
11 months ago

@wonderdog4 Do drop a safe link in to a fixed page though, we'll try and see if there is something we might be able to change in a safe manner for themes.

#4 @wonderdog4
11 months ago

@hnla Sorry. I don't know what you are saying. I can tell you that it was an easy fix.

I just put this into style.css in my child theme:
https://gist.github.com/anonymous/584ccf9085aff0761a9abde3bab86840

Note: See TracTickets for help on using tickets.