Skip to:
Content

BuddyPress.org

Opened 3 years ago

Closed 3 years ago

#7376 closed enhancement (wontfix)

UX confusion: Inconsistent definitions of activity in members loop template functions

Reported by: ryanrain Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Templates Keywords: close
Cc:

Description

hey all!
a client recently brought to my attention what she considers to be a bug: in places such as the members loop and member profile headers, some users are reported to have been active, but, confusingly, that activity is not shown.

looking around in the code, it appears that the bp_member_last_active() function includes lotsa different kinds of activity (eg. activity comments) in its calculation of how much time has passed since the user interacted with the site, but then the bp_member_latest_update() function seems to not include forum replies or activity comments etc., just updates.

I'm filing this ticket to argue that functions used in the member loop should have a consistent, common definition of which kinds of activity should be considered and shown. My client asked that i make the site include latest activity comments in the members loop, but i'm not sure if that would be best as default buddypress behaviour since comments sometimes make no sense out of context. eg. "yeah, i totally agree!"

this started as a https://buddypress.org/support/topic/last_activity-empty-in-members-loop/#post-261694(support request) for advice as to how to print out a user’s most recent activity regardless of its type? Can anyone point me in the right direction? Thanks everyone!

Change History (3)

#1 @hnla
3 years ago

But bp_member_latest_update() is just that a user status update i.e the thing you fill in above the act stream, what we refer to as the 'what's new {user}` textarea.

The member loop displays this but is not intended to show any other user activity as that would likely be far to much to ever show.

Thus the members loop isn't inconsistent it's consistent with what was intended to be shown there if that makes sense?

As a developer though you have licence to modify the loop to show any data you or the client wishes, a common one is to drop profile meta into members loop items.

I don't think there's anything to 'fix' here.

#2 @slaFFik
3 years ago

  • Keywords close added
  • Version 2.7.2 deleted

I agree with @hnla and propose to close this ticket.
For me it's obvious that bp_member_latest_update() is about updates, and members loop cares only about such updates (similar to some other social networks, like VK.com).

And the request of @ryanrain client is too project specific.

#3 @slaFFik
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.