Skip to:

Opened 8 years ago

Last modified 7 years ago

#7195 new enhancement

Throw a notice when activating BP on a site that doesn't meet system requirements

Reported by: boonebgorges's profile boonebgorges Owned by:
Milestone: Awaiting Contributions Priority: normal
Severity: normal Version:
Component: Core Keywords:


When BP requires a version of PHP higher than what WP requires, you could have people activating BP on a WP site that can't run BP. We should do the following:

  • make sure our loader file is compatible with the minimum version of PHP supported by WordPress
  • when BP is activated on a WP install that doesn't meet PHP requirements, throw an admin notice and don't load the rest of BP's files

Attachments (1)

7195.01.patch (664 bytes) - added by DJPaul 8 years ago.

Download all attachments as: .zip

Change History (7)

#1 @DJPaul
8 years ago

  • Milestone changed from Future Release to 2.8

#2 @djpaul
8 years ago

In 11206:

Update Composer PHP requirement to 5.3+, and shrinkwrap latest NPM packages.

See #7195

#3 @djpaul
8 years ago

In 11207:

Unit Tests: adieu, PHP 5.2.

BP 2.8 drops support for PHP 5.2. See #7195

8 years ago

#4 @DJPaul
8 years ago

7195.01.patch is really just a proof of concept of showing an admin notice if you're running PHP < 5.3 to start discussion.

I personally think we should intentionally use die to quit processing, so that WordPress falls back and never activates the plugin. See screenshot for a reminder of that behaviour:

#5 @DJPaul
8 years ago

I came across a Twitter discussion about this sort of thing, and found another plugin's approach to this:

#6 @DJPaul
7 years ago

  • Milestone changed from 2.8 to Future Release
Note: See TracTickets for help on using tickets.