Skip to:
Content

Opened 22 months ago

Closed 21 months ago

Last modified 19 months ago

#6962 closed defect (bug) (fixed)

Profile Cover not working when we define a custom BP_XPROFILE_SLUG

Reported by: Maniou Owned by: r-a-y
Milestone: 2.6 Priority: normal
Severity: normal Version: 2.4.0
Component: Media Keywords: has-patch commit
Cc:

Description

Hello,

When we define a custom BP_XPROFILE_SLUG for example :

define ( 'BP_XPROFILE_SLUG', 'profil' );

The profil cover is not working because of this condition in /buddypress/bp-core/bp-core-attachments.php line 1036

if ( 'profile' === $current_component ) {

Can we compare with the name of the custom profil slug instead of the hardcoded profile text ?

Thank you !

Attachments (1)

6962.01.patch (446 bytes) - added by r-a-y 22 months ago.

Download all attachments as: .zip

Change History (9)

#1 @r-a-y
22 months ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 2.6
  • Version changed from 2.5.0 to 2.4.0

Thanks for the report. I can confirm the issue.

I've attached a patch that should fix this.

Last edited 22 months ago by r-a-y (previous) (diff)

@r-a-y
22 months ago

#2 @r-a-y
22 months ago

  • Priority changed from high to normal

This ticket was mentioned in Slack in #buddypress by djpaul. View the logs.


22 months ago

This ticket was mentioned in Slack in #buddypress by dcavins. View the logs.


22 months ago

#5 @imath
21 months ago

  • Keywords commit added

01.patch looks good to me, thanks a lot @r-a-y.

Last edited 21 months ago by imath (previous) (diff)

This ticket was mentioned in Slack in #buddypress by imath. View the logs.


21 months ago

#7 @r-a-y
21 months ago

  • Owner set to r-a-y
  • Resolution set to fixed
  • Status changed from new to closed

In 10707:

Cover Image: Fix issue when a custom BP_XPROFILE_SLUG is in use.

Fixes #6962.

#8 @DJPaul
19 months ago

  • Component changed from Component - Attachments to Media
Note: See TracTickets for help on using tickets.