Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#6837 closed defect (bug) (no action required)

Activity load more ajax does not respect theme templates

Reported by: scottopolis's profile scottopolis Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.7
Component: Core Keywords: reporter-feedback
Cc:

Description

Problem: Clicking load more on the activity feed gets more items via ajax, but it loads the buddypress/bp-templates/bp-legacy/buddypress/activity/activity-loop.php and entry.php template file instead of the file in my theme.

I have a theme with the buddypress/bp-templates/bp-legacy/buddypress folder in it, and I customized the markup in the activity template files. Load more uses the template files from the plugin, not my theme, only when load more is clicked.

To replicate: start with a custom theme, copy buddypress/bp-templates/bp-legacy/buddypress folder into it. Edit buddypress/bp-templates/bp-legacy/buddypress/activity/activity-loop and entry.php files so you know they are from the theme, not the plugin. Go to activity, load more, you will see your custom template files are not respected.

Change History (4)

#1 @hnla
8 years ago

@scottopolis The loading of custom templates in a theme/child theme works as expected, I can't reproduce the issue you describe.

To be clear in your theme or child theme what is the exact path/directory names you're using to hold the overloaded bp templates?

#2 @r-a-y
8 years ago

  • Keywords reporter-feedback added
  • Version changed from 2.4.0 to 1.7

To replicate: start with a custom theme, copy buddypress/bp-templates/bp-legacy/buddypress folder into it.

You shouldn't copy the entire folder. Only copy the templates you need to override.

If it is possible, can you start your BuddyPress theme modification from scratch?

For example, in your theme's folder, just copy over the activity-loop.php and entry.php templates.

  • /wp-content/themes/YOUR-THEME/buddypress/activity/activity-loop.php
  • /wp-content/themes/YOUR-THEME/buddypress/activity/entry.php

And make your modifications. Don't do anything else. Now, check the AJAX functionality on the Activity Directory page to see if your mods show up.

#3 @DJPaul
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing due to no further reporter feedback, because we'd need some experimentation to figure out what might be happening here.

#4 @DJPaul
8 years ago

  • Component changed from API to Core
Note: See TracTickets for help on using tickets.