Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 6 years ago

#6802 closed defect (bug) (no action required)

I'm having an issue with the latest Buddypress update which I just. Redirect Loop

Reported by: Dono12 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.4.0
Component: Members Keywords:
Cc:

Description (last modified by boonebgorges)

I'm using this code snippet to redirect registering users
to the default Wordpress Registration form. Located in bp_custom.php

// hacks and mods will go here  This Version is plugin folder
/**
 * Disables BuddyPress' registration process and fallsback to WordPress' one.
 */
function my_disable_bp_registration() {
  remove_action( 'bp_init',    'bp_core_wpsignup_redirect' );
  remove_action( 'bp_screens', 'bp_core_screen_signup' );
}
add_action( 'bp_loaded', 'my_disable_bp_registration' );
add_filter( 'bp_get_signup_page', "firmasite_redirect_bp_signup_page");
    function firmasite_redirect_bp_signup_page($page ){
        return bp_get_root_domain() . '/wp-signup.php'; 
 }

The problem I'm having is registration is now inopperable.
When the default Wordpress register button is clicked it takes
the user to an error page:

This webpage has a redirect loop

ERR_TOO_MANY_REDIRECTS.

I know the problem stems from Buddypress because during my trouble shooting I've disabled all plugins and the problem was narrowed down to the Buddpress
plugin. Does anyone have a fix for this. During my research to fix this issue I've came acrooss others with similar issues.

http://wordpress.stackexchange.com/questions/211687/too-many-redirects-error-when-redirecting-buddypress-register-page-to-wordpress

Change History (3)

#1 in reply to: ↑ description @Dono12
6 years ago

Replying to Dono12:

I'm using this code snippet to redirect registering users
to the default Wordpress Registration form. Located in bp_custom.php

hacks and mods will go here This Version is plugin folder
/

function my_disable_bp_registration() {
  remove_action( 'bp_init',    'bp_core_wpsignup_redirect' );
  remove_action( 'bp_screens', 'bp_core_screen_signup' );
}
add_action( 'bp_loaded', 'my_disable_bp_registration' );
add_filter( 'bp_get_signup_page', "firmasite_redirect_bp_signup_page");
    function firmasite_redirect_bp_signup_page($page ){
        return bp_get_root_domain() . '/wp-signup.php'; 
 }

The problem I'm having is registration is now inopperable.
When the default Wordpress register button is clicked it takes
the user to an error page:

This webpage has a redirect loop

ERR_TOO_MANY_REDIRECTS.

I know the problem stems from Buddypress because during my trouble shooting I've disabled all plugins and the problem was narrowed down to the Buddpress
plugin. Does anyone have a fix for this. During my research to fix this issue I've came acrooss others with similar issues.

http://wordpress.stackexchange.com/questions/211687/too-many-redirects-error-when-redirecting-buddypress-register-page-to-wordpress


Found A Solution:

CHANGE

[return bp_get_root_domain() . '/wp-signup.php';]

TO

 return bp_get_root_domain() . '/wp-login.php?action=register';
Last edited 6 years ago by Dono12 (previous) (diff)

#2 @boonebgorges
6 years ago

  • Description modified (diff)

#3 @boonebgorges
6 years ago

  • Component changed from API - Sign ups & Activation to Component - Members
  • Milestone Awaiting Review deleted
  • Priority changed from omg pizza to normal
  • Resolution set to invalid
  • Severity changed from critical to normal
  • Status changed from new to closed

I'm assuming that the problem is that you're not running Multisite. If you are not running Multisite, wp-signup.php redirects you to wp_registration_url(); BP filters this value using bp_get_signup_page(); but you are in turn filtering bp_get_signup_page to go back to wp-signup.php.

At a glance, your function firmasite_redirect_bp_signup_page() is probably redundant, especially if you're changing it to redirect to wp-login.php?action=register.

In any case, it appears that the snippet you copied and pasted was intended for a different configuration, and that it's not a BP bug. Thanks for the ticket.

Note: See TracTickets for help on using tickets.