Skip to:
Content

BuddyPress.org

Opened 4 years ago

Closed 3 years ago

#6593 closed defect (bug) (no action required)

Subnav item added by bp_core_new_subnav_item under Friends navigation is not appearing.

Reported by: pareshradadiya Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Friends Keywords: has-patch dev-feedback 2nd-opinion
Cc:

Description

BuddyPress Friends navigation does not showing subnav item when displayed_user_id != loggedin_user_domain

Attachments (1)

subnav_friends.diff (560 bytes) - added by pareshradadiya 4 years ago.
Proposed fix

Download all attachments as: .zip

Change History (7)

@pareshradadiya
4 years ago

Proposed fix

#1 in reply to: ↑ description @pareshradadiya
4 years ago

Replying to pareshradadiya:

BuddyPress Friends navigation does not showing subnav item when displayed_user_id != loggedin_user_id

#2 @DJPaul
4 years ago

  • Keywords dev-feedback added

Thanks for the patch, @pareshradadiya! I'm sorry it took so long for us to take a look.

I suspect it's intentional. The original code (which has moved around a lot over the years) was introduced in r2170, when the theme was added. I tried to remove this before; see r4314, r4314, #3046, but it had to be reverted.

I'm inclined to not want to change this in bp-legacy/bp-default because it's how it always has been (and maybe in a new template pack in the future, we wouldn't do the same).

#3 @DJPaul
4 years ago

  • Milestone changed from Awaiting Review to Under Consideration

#4 @DJPaul
4 years ago

  • Keywords 2nd-opinion added

#5 @DJPaul
3 years ago

  • Milestone changed from Under Consideration to Awaiting Review

#6 @DJPaul
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

This report has insufficient traction or interest in the suggestion, so I'm closing it.

Note: See TracTickets for help on using tickets.