Skip to:
Content

BuddyPress.org

Opened 5 years ago

Closed 5 years ago

#6284 closed defect (bug) (fixed)

Invalid form label on Components Settings screen

Reported by: DJPaul Owned by: djpaul
Milestone: 2.3 Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Cc:

Description (last modified by DJPaul)

In wp-admin Settings > BuddyPress, there is no form <label> value printed for the check boxes on the Components screen because of a sprintf vs printf typo.

Beyond fixing this, we can go one step better and make the component name be the label element for the corresponding check box. This will bring enhancements to all users, because you'll be able to click/touch the component name to toggle the check box -- something I've personally been doing for years and getting frustrated that it never worked.

Change History (2)

#1 @DJPaul
5 years ago

  • Description modified (diff)

#2 @djpaul
5 years ago

  • Owner set to djpaul
  • Resolution set to fixed
  • Status changed from new to closed

In 9605:

Administration: fix valueless <label> element for the Settings > BuddyPress > Components screen.

Originally caused by a simple typo, but we can enhance this further by making the component name the label for the corresponding check box.
Doing so lets us click/touch the component name to toggle its check box.

Fixes #6284

Note: See TracTickets for help on using tickets.