Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#6198 closed defect (bug) (no action required)

buddypress private group forums showing up in activity

Reported by: milenushka's profile milenushka Owned by:
Milestone: Priority: high
Severity: normal Version: 2.2
Component: Groups Keywords:
Cc:

Description

Hello moderators. I have found this issue recently and have read all the threads I could find, with no success of solving it.

My PRIVATE group’s forum topics and replies show up in the activity stream.
I tested it thoroughly and what I found was it happens only to private group forums.
Not private forums that are unattached to groups.

bbpress 2.5.4
buddypress 2.1.1 and also after the update 2.2
wp 4.0.1

action taken:
1.turned off all the plugins but buddypress and bbpress

  1. tested with another theme
  2. also used the Tools > Forums to recaculate and resync the forums

the problem remains.

Please help.

p.s the previous ticket was closed 15 months ago, but i found people
describingg this issue from 6 months ago. so clearly it remains unsolved.
see the last reply here
https://buddypress.org/support/topic/private-group-posts-appearing-in-
activity-stream-to-non-members/

https://buddypress.org/support/topic/private-group-posts-appearing-in-activity-stream-to-non-members/

https://buddypress.org/support/topic/private-group-topics-appearing-in-activity-stream-help/

https://buddypress.org/support/topic/bugs-between-bbpress-and-buddypress/

https://bbpress.trac.wordpress.org/ticket/2327

thankx

Change History (13)

#1 @milenushka
9 years ago

Hi, I have more info now.
I can confirm that this is what is happening:
If a group is created as private and a forum is created with it- it will be a private forum and its activity will remain invisible to non group members.
If a private group is created and an existed forum is added to it- this forum need to be changed to private- otherwise the forum will remain public, even though the group attached to it is private- and the activity of the forum will be public.
Same goes for a public group+ forum , that is created together and later group setting are set to private. Forum remains public- forum’s activity -too.
Is there something to be done with the buddypress-bbpress integration to make this work?
Creating a function that will make a forum private too- if the group it was attached to becomes private?
My thread in buddypress forums
https://buddypress.org/support/topic/forum-in-private-groups/
another person who found this
https://buddypress.org/support/topic/forum-in-private-groups/
thank you

This ticket was mentioned in Slack in #buddypress by boone. View the logs.


9 years ago

#3 @netweb
9 years ago

  • Component changed from API to Component - Groups
  • Priority changed from highest to normal
  • Severity changed from critical to normal

Related: #bbPress2599

Workaround: Running the bbPress repair tool "Recalculate private and hidden forums" should resolve this issue.

#4 @milenushka
9 years ago

  • Priority changed from normal to high
Workaround: Running the bbPress repair tool "Recalculate private and hidden forums" should resolve this issue.

@netweb, it was tested and it doesn't.

#5 @DJPaul
9 years ago

@netweb since you commented previously :) any more insight on this if it is a bbPress issue or not?

#6 @DJPaul
9 years ago

  • Milestone changed from Awaiting Review to Under Consideration

#7 @r-a-y
9 years ago

  • Milestone Under Consideration deleted
  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed upstream in bbPress - #BB2599.

You'll have to wait until bbPress 2.6 is released for this to take effect.

#9 @r-a-y
8 years ago

#6888 was marked as a duplicate.

#10 @r-a-y
8 years ago

In 10616:

Emails: Add <title> tag to the WP Customizer and admin email preview.

Props offereins.

See #6198.

Edit: Commit meant to reference #6918 and not this ticket! :(

Last edited 8 years ago by r-a-y (previous) (diff)

#11 @cjerrells
7 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hi,

I am having this issue.

WordPress 4.7.4
BuddyPress 2.8.2
bbPress 2.5.12

Group is set as private.
The group's Forum is set as public.

The forum is (correctly) not accessible to non-members of the group. However new discussions and replies generate BuddyPress activity items which are visible to all users of the site including non-members.

I have tried:

  • Setting the forum as private too - but then it didn't even show up in the group. I got "This group does not currently have a forum." on the Forum tab of the group's page.
  • Using the Repair tools "Recalculate private and hidden forums" and "Repair BuddyPress Group Forum relationships".
  • Removing the forum from the Group and adding it back again.
  • Setting the Group as Public and then back to Private again (since it seemed like that might trigger the fix committed on this trac ticket)

None of these solved it.

I'm happy to do whatever I can to help diagnose this further, but I'm not really sure what else to try at this point.

#12 @r-a-y
7 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Thanks for the report, but please read comment:7, this is a bbPress issue, not a BuddyPress one.

#13 @cjerrells
7 years ago

Ah, okay, thanks! Sorry I missed that.

Note: See TracTickets for help on using tickets.