Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#5920 closed defect (bug) (duplicate)

Pot file on trac (all versions)

Reported by: danbp Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords:
Cc:

Description

Want to mention a curious issue with pot files on Trac. Recent changes for 2.0.x are affecting the whole Trac, which is probably not intended initially.

Actually, all versions are showing on screen a pot file generated of r8832
(tag, branches & trunk) in the Age column.

Also, as example and even if it's an archive now, the 1.0 version contains a pot file generate 9 mounth ago from r7720 in the bp-languages folder.

And all versions have now a pot file at the BP root (outside of the bp-languages folder) generated 7 weeks ago from r8832.

Change History (4)

#1 @DJPaul
7 years ago

potbot went through and put a .po at the root of all BP tags/branches/trunk a month or so ago, so it's not surprising you find those in any version -- even if the older versions also have a copy in /bp-languages/.

Will let @boonebgorges comment on the rest as I've lost trac of where we are with our glotpress integration and how things are meant to work.

#2 @boonebgorges
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I'm still working with the wordpress.org team to sort out the details, but I believe our goal is to disable potbot (again) and stop storing .pot files in buddypress.svn.wordpress.org. A .pot will be included in BP when it's distributed on wordpress.org, and strings will be regularly updated for translation at translate.wordpress.org/projects/buddypress/. See https://buddypress.trac.wordpress.org/ticket/5621#comment:15 and follow-up comments for more details.

While having these incorrect .pot files here is a bit annoying, I don't think it causes any active harm. And we should be able to remove them as part of resolving #5621. I'm going to close this ticket as a duplicate of that one. Thanks for the report, danbp.

#3 @johnjamesjacoby
7 years ago

  • Component changed from Backwards Compatability to Locale - i18n

#4 @DJPaul
5 years ago

  • Component changed from Locale - i18n to I18N
Note: See TracTickets for help on using tickets.