Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5474 closed defect (bug) (fixed)

Conditional tag

Reported by: SGr33n Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc: johnjamesjacoby

Description

hi :)

If BuddyPress and bbPress are both enabled, some BuddyPress pages are positive to is_bbpress() conditional tag.

The pages are those starting with /users/... except the users list.

Change History (4)

#1 @DJPaul
6 years ago

  • Cc johnjamesjacoby added
  • Milestone changed from Awaiting Review to Future Release

CC'ing JJJ; I suspect we'll need to move this ticket over to the bbPress trac since the problem is inside a bbPress function.

#2 @johnjamesjacoby
6 years ago

  • Milestone Future Release deleted
  • Resolution set to fixed
  • Status changed from new to closed

This should probably be a ticket over on the bbPress.org trac, but right now this is more of a "known consequence" than a bug. bbPress yields to BuddyPress's profiles, which is why it returns true in these conditions, but it's also how bbPress knows how to fit into the Forums section of BuddyPress member profiles.

Going to close this ticket here for now. It's likely annoying, and maybe could be done somewhat more eloquently, but not really a bug quite yet.

If you have a specific use-case for why this behavior should be changed, please open a ticket over at bbpress.trac.wordpress.org.

#3 @SGr33n
6 years ago

Speaking of bbPress is also an issue that all buddypress pages have the body class bbpress.

#4 @SGr33n
6 years ago

The specific use-case could surely is the use of a conditional widget plugin, like the one in Jetpack or "widget logic".

Last edited 6 years ago by SGr33n (previous) (diff)
Note: See TracTickets for help on using tickets.