Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 6 years ago

#5359 closed defect (bug) (fixed)

Groups wp-admin UI autocomplete should exclude spammed members

Reported by: DJPaul Owned by: imath
Milestone: 2.0 Priority: normal
Severity: normal Version: 1.7
Component: Administration Keywords: has-patch commit
Cc:

Description

The user autocomplete in the Groups wp-admin screen returns users who have been marked as spam. This was observed on a multisite install.

The issue is in bp_groups_admin_autocomplete_handler() where we use get_users(). I think BP_User_Query should be updated to not fetch spammed users by default.

Attachments (1)

5359.diff (1.2 KB) - added by imath 6 years ago.

Download all attachments as: .zip

Change History (4)

@imath
6 years ago

#1 @imath
6 years ago

  • Keywords has-patch added

5359.diff is excluding users marked as spam ;)

#2 @boonebgorges
6 years ago

  • Keywords commit added
  • Milestone changed from Awaiting Review to 2.0

Looks good!

#3 @imath
6 years ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 8147:

Exclude members marked as spam from Group Admin autocomplete results

In Groups /wp-admin UI, the autocomplete feature to add a new member to the group need to exclude spammed users.

props DJPaul

Fixes #5359

Note: See TracTickets for help on using tickets.