Skip to:
Content

Opened 5 years ago

Closed 4 years ago

#534 closed enhancement (fixed)

Provide typical Forum Moderation functions in group member forum

Reported by: johnjamesjacoby Owned by:
Milestone: Priority: major
Severity: Version: 1.0
Component: Keywords: bbpress, forum
Cc:

Description

Not sure if this has been put anywhere in the trac or not, but per this topic in forums (http://buddypress.org/forums/topic.php?id=1403) I'm helping out a non-english speaking individual by formally requesting it here.

Basically it would be nice for key masters/admins/moderators to have the typical edit/delete/undelete/sticky/close moderation functions available when viewing the forum from the group page.

Change History (5)

comment:1 jeffca5 years ago

It would also be nice if the bbPress "Lock post editing after" setting was used for all users to edit their own topics for x minutes.

comment:2 apeatling5 years ago

  • Milestone changed from Forums 1.0 to Forums 1.1

Absolutely, the 1.0 of forums is simple by design. These sorts of features will find their way in as time progresses and the setup simplifies.

comment:3 anonymous5 years ago

  • Milestone Forums 1.1 deleted

Milestone Forums 1.1 deleted

comment:4 DJPaul5 years ago

Most of these features are in BP 1.1/trunk.

comment:5 johnjamesjacoby4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

I think all of the relevant functions are here. All that's missing is the move-to select box, and it's doubtful the ability to move topics from one group to another should be a core function.

As bbPress integration grows, more functions will be built into the API. Marking this as resolved since everything is accounted for or on the way soon.

Note: See TracTickets for help on using tickets.