Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#5152 closed defect (bug) (worksforme)

404 on profile edit

Reported by: elemunjeli Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.8.1
Component: Core Keywords: needs-patch reporter-feedback
Cc:

Description

Installed twice on WP 3.5.2 and group 1, the base group, is not creating. Uninstalled and reinstalled with various other plugins deactivated to no avail. This is an ongoing issue which is receiving no meaningful answer in support forums beyond 'Reinstall it'. Without a base group, the profile edit tab throws a 404 error. I've tried the plugin on three themes including twenty-twelve and am using simply the BP default theme.

The site is at http://democracylab.org

You can see the 404 at http://democracylab.org/members/munjeli/profile/edit/group/1/

If there's a way to code around this, I'll do it, I'm a dev, but the lack of attention is leaving me cold.

Change History (4)

#1 @DJPaul
8 years ago

  • Keywords reporter-feedback added

Super odd. So an install of BuddyPress is not creating the default group for the Extended Profiles component? Are there any relevant messages in the MySQL or PHP error logs?

When you say "with various other plugins deactivated", I assume that you've also tried with *no* other plugins active (including nothing in a bp-custom.php file, if you've added that), or in mu-plugins?

#2 @DJPaul
8 years ago

Hi elemunjeli - probably you don't have the original logs, but if you see this, could you read my first note and perhaps try to recreate the problem on a new install?

#3 in reply to: ↑ description @johnjamesjacoby
7 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to elemunjeli:

I'm a dev, but the lack of attention is leaving me cold.

There are only two touch-points with this: bp_core_install_extended_profiles() and dbDelta(). The default field and field-group are created there, and have checks to make sure duplicates are not created. Would be odd that the tables are created, and the fields are not. Possible there's a MySQL compatibility issue in there somewhere.

If you can consistently reproduce, I agree with Paul that getting information from the logs would be the most helpful for us. Until then, going to close this as 'worksforme'. Reopen if more details come in.

#4 @johnjamesjacoby
7 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.