Skip to:
Content

Opened 12 months ago

Closed 12 months ago

Last modified 2 months ago

#4937 closed defect (bug) (fixed)

Popular Members Widget - Doesn't show all members

Reported by: allenpayne Owned by: boonebgorges
Milestone: 1.8 Priority: normal
Severity: normal Version: 1.7
Component: Core Keywords:
Cc: sam3dus@…, mert@…

Description

Hi,

I just updated to wp 3.5.1 and buddypress 1.7 and i have an unusual problem with the Members widget.

I currently have 3k+ members on my site and my top member has 400+ friends.

When i add the Members widget to the sidebar and click on Popular…it shows a list of member starting with the member with 96 friends.

For some reason it doesn’t show the top members (starting with the one with 400+ friends).

Any ideas?

*
I tried to replace the bp-core-widgets.php file with the one from the previous version, but it didn’t work.

Attachments (1)

4937.diff (609 bytes) - added by merty 12 months ago.

Download all attachments as: .zip

Change History (19)

comment:1 boonebgorges12 months ago

  • Keywords reporter-feedback added

Hm. Please try putting the following into your bp-custom.php file, and see what happens:

add_filter( 'bp_use_legacy_user_query', '__return_true' );

If that fixes it, it'll suggest that there's a bug in BP_User_Query.

comment:2 allenpayne12 months ago

Thanks for getting back to me Boone.

This fixed the problem.

Is this a good solution? Can i leave it like that?

comment:3 boonebgorges12 months ago

  • Keywords reporter-feedback removed
  • Milestone changed from Awaiting Review to 1.8
  • Severity changed from major to normal

Yes, you can leave it like that, until this ticket has been marked as fixed and the fix has gone into a release version.

comment:4 allenpayne12 months ago

Ok, Boone. Thanks for your help. I really appreciate it.

comment:5 follow-up: boonebgorges12 months ago

Thanks for reporting the issue! I may ask you to test any potential fixes.

comment:6 shanebp12 months ago

  • Cc sam3dus@… added

comment:7 in reply to: ↑ 5 allenpayne12 months ago

Replying to boonebgorges:

Thanks for reporting the issue! I may ask you to test any potential fixes.

Sure, Boone. Just let me know...

merty12 months ago

comment:8 merty12 months ago

  • Keywords has-patch needs-testing added

This should fix it.

comment:9 AllenPayne12 months ago

Your patch works. Thank you @merty.

Last edited 12 months ago by AllenPayne (previous) (diff)

comment:10 merty12 months ago

  • Keywords needs-testing removed

You're welcome! Thanks for testing it!

comment:11 merty12 months ago

  • Cc mert@… added

comment:12 boonebgorges12 months ago

Patch looks great, thanks merty!

comment:13 boonebgorges12 months ago

  • Owner set to boonebgorges
  • Resolution set to fixed
  • Status changed from new to closed

In 6996:

Convert total_friend_count to SIGNED before attempting to sort with it

This fixes issues in BP_User_Query where the 'popular' sort order was sorting
by friend count interpreted as a string (ie, alphabetically) instead of
numerically.

Fixes #4937

Props merty

comment:14 CarlosRovira2 months ago

  • Keywords has-patch removed

Hi I'm using latest version 1.9.2, and this bugs seems still there. I tried the fix exposed with no luck.

Is a new ticket for this problem? (if so, some could point me to it?)

If there's no ticket I will create a new one.

Thanks in advance

comment:15 boonebgorges2 months ago

  • Keywords reporter-feedback added

CarlosRovira - Can you please give further details?

comment:16 CarlosRovira2 months ago

Thanks Boone for your quickly response:

The site where you can see the problem is: http://www.madeinflex.com

In the home near the final you can see "USUARIOS EN LA COMUNIDAD DE MADE IN FLEX"

This is the Member User BuddyPress Widget.

I have 36 people configured. I expect to see 32 people (people already in the community). And get up to 36 when have enough people to show.

But right now only shows 20. If I click "Activo" label it shows 32 people (is what is expected). And if I come back to "Nuevos", it show 32.

So the problem seems to be on the load of the plugin.

I don't use any custom code, just plugins, and this widget seems to be BP core widget, isn't it?

I'll try the links you comment to see If I can fix it

comment:17 boonebgorges2 months ago

  • Keywords reporter-feedback removed

Thanks for the additional details, CarlosRovira. This appears to be a separate problem, related to the 'max' or 'per_page' parameter. Could you please open a separate ticket, describing what you describe above? And be sure to share the exact settings you set up when you created the widget at Dashboard > Appearance > Widgets. Thanks!

comment:18 CarlosRovira2 months ago

HI Boone,

ticket created as you requested

https://buddypress.trac.wordpress.org/ticket/5410

Thanks!

Carlos

Note: See TracTickets for help on using tickets.