Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4812 closed enhancement (fixed)

1.7 lost group forum option in admin

Reported by: modemlooper's profile modemlooper Owned by:
Milestone: Priority: normal
Severity: major Version: 1.7
Component: Forums Keywords: reporter-feedback
Cc: johnjamesjacoby

Description

When you install bbPress it creates a forum tab on each group. This should not happen unless you activate forums on that group.

There really needs to be an option put back into the component admin screen that allows you to turn off the group forum option site-wide. If you want a site with separate forums from groups it's silly to have a tab that says "forums" and then an option to turn it on when you have no desire to run group forums.

Change History (13)

#1 @boonebgorges
11 years ago

  • Cc johnjamesjacoby added
  • Component changed from Core to Forums
  • Milestone changed from Awaiting Review to 1.7

When you install bbPress it creates a forum tab on each group.

You're talking about the bbPress *plugin*, right? You are correct that the tab should only show up when forums have been activated for that group. If it's showing up all the time, it's a bbPress 2.3 bug.

There really needs to be an option put back into the component admin screen that allows you to turn off the group forum option site-wide.

I don't know about *putting anything back*. The 1.5-1.6 Forums component option refers to bbPress 1.x, the standalone software. We removed the option from the component screen by default because we don't want people to be activating legacy forums anymore - existing installations are fine indefinitely, but we don't want any new users of bbPress 1.x in BP.

That said, I think it is a good idea to allow the site admin to toggle the group forum functionality altogether. Whether this is done through a UI toggle or a filter/constant is not entirely clear to me. In either case, this would primarily be a feature request for bbPress.

Would like to get jjj's feedback on this issue.

#2 @modemlooper
11 years ago

bbPress is forcing forums into groups. This should not be allowed. When you activate bbPress it should not be able to automatically let group admins create forums. If a user installs bbP and then doesn't realize this because there is no way to know as there is no dialog about group forums option being initiated into every group including a forum tab.

This is all easily fixed by adding back a group forums option in the admin that is off by default and hidden if bbP is not installed.

#3 @boonebgorges
11 years ago

This should not be allowed.

Agreed. That's what I said in my previous comment. (Assuming you're talking about bbPress plugin.)

This is all easily fixed by adding back a group forums option in the admin that is off by default and hidden if bbP is not installed.

You say "adding back". It is not a case of adding anything back. The existing option in the BP component screen has nothing to do with the bbPress plugin. So something new has to be designed and coded.

#4 @modemlooper
11 years ago

There used to be a forums option int eh admin. That's what i'm referring to. Anyhoo, a option to shut off group forums will be needed.

#5 @DJPaul
11 years ago

  • Keywords dev-feedback removed
  • Milestone 1.7 deleted
  • Resolution set to invalid
  • Status changed from new to closed

I've spoken with John and we can't see what the use case is for an option to turn off group forums. Additionally, going forwards, all controls or options for forums needs to be in bbPress.

#6 @boonebgorges
11 years ago

we can't see what the use case is for an option to turn off group forums

Really? You can't imagine a case where the admin might want sitewide forums but not group forums?

In any case, I agree that it's a bbPress issue.

#7 @modemlooper
11 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

What? no reason? I need to turn it off on 3 sites as soon as I upgrade them to 1.7. You really don't think people want groups without forums?

Besides, you are missing an important issue with this ticket. If you have a WordPress install and you add BP it shows forum tabs in the groups when bbPress is not installed. You don't see an issue with this?

I'm dumbfounded that you guys just dismissed this so easily. This is major, not something to decide amongst yourselves. This project is still community developed, yes?

#8 @r-a-y
11 years ago

  • Keywords reporter-feedback added

modemlooper: I tried to duplicate your issue using latest trunks of BuddyPress and bbPress.

I created a new group without enabling the forum option in the group creation process and I do not see a "Forum" tab on the new group's homepage.

Are you using the latest, bleeding versions of both BP and bbP?

#9 @modemlooper
11 years ago

yes, yesterday, fresh everything. The forum tab showed in every group and when you click it said forums were not installed. That's just one issue. Sites are not going to want admins to be able to turn on a group forum if they do not want their site to have group forums. So it's either a yes to group forums or no to site forums. 1.6 > we had option to run sitewide or group forums. now we have to have both if bbPress is installed.

Last edited 11 years ago by modemlooper (previous) (diff)

#10 @r-a-y
11 years ago

Gotcha, modemlooper.

There should be a setting in bbPress' admin screen to enable / disable group forums for BuddyPress.

Disable it and you should be good to go.

  • Login to the WP dashboard
  • Navigate to "Settings > Forums"
  • Scroll down to the "BuddyPress" section and uncheck "Allow BuddyPress Groups to have their own forums"

That should fix your issue, but let us know if it doesn't.

#11 @modemlooper
11 years ago

yup,

Here's the scenario:

You install bbPress, you have a site wide forum. Great. You have admins of groups, they turn on a group forum. You do not want the group admins the ability to do this. We lost this option in 1.7

#12 @modemlooper
11 years ago

Well that's a hidden setting! LOL Should this be turned off by default? Adding a codex page for this. ;)

Last edited 11 years ago by modemlooper (previous) (diff)

#13 @modemlooper
11 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.