Skip to:
Content

#4799 closed defect (bug) (invalid)

Glitch in enabling Group Forums using Sitewide Forums

Reported by: mercime Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Forums Keywords:
Cc:

Description

WP 3.5.1, BuddyPress 1.6.4 and bbPress 2.2.4 fresh installations:

  • XAMPP installation
  • Production Multisite installation where BP is installed in blog_site 2

Group Admin has to enable Group Forum twice in order to create group forum and the link to show up in group's main navigation.

To recreate:

  • During Installation Wizard, disable Discussion Forums component
  • Install bbPress
  • Forum > Add New - "Group Forums" and change attribute type from Forum to Category and Publish
  • Settings > Forums go to BuddyPress section and check Allow BP group to have forum. Select Group Forums created above for parent and Save
  • Go example.com/groups/create and create a new Group, "ABC"
  • Step 3 of ABC Group Creation, check "Yes, I want to have a group forum" and continue to complete the Group creation process.
  • There's no "Forum" link in the main navigation of the "ABC" Group
  • Click on ABC Group's "Admin" link
  • Click on "Forum" link in Sub navigation
  • "Yes, I want to have a group forum" is unchecked. Check it again and click "Save"
  • Forum link is now available in ABC Group's main navigation.

Change History (2)

comment:1 mercime15 months ago

Update: Installed bbPress 2.3 beta 2 and the issue is fixed i.e., the Forum link shows up as expected in group's main navigation the first try :-)

comment:2 r-a-y15 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Yup, this is addressed in the new bbPress beta!

At first, I thought you were trying to use both bbPress and BuddyPress' built-in forums enabled at the same time. The BP Courseware plugin relies on BP's built-in forums, so this dual setup is something we should try and support as well.

Note: See TracTickets for help on using tickets.