Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

#4800 closed defect (bug) (fixed)

Links in welcome screens and user config.

Reported by: imath Owned by:
Milestone: 1.7 Priority: normal
Severity: normal Version: 1.7
Component: Administration Keywords:
Cc:

Description

Hi,

Just installed a new WordPress config, then the version 1.7. Just after I'm redirected to the beautiful Welcome screen at http://buddy17.dev/wp-admin/index.php?page=bp-about&is_new_install=1

The problem is that some links in the welcome text leads to a 404 :

1- as i just installed WordPress, i haven't set my permalinks, so in the "Getting started" first paragraph the links "Activity" and "Members" leads to 404.

i suggest to disable the 2 links in that case as once on the Components panel, a message shows and invites us to update permalinks.

2- as it's a first BuddyPress install, i haven't activated the group component, so in the "Group management" paragraph, when i click on the link "Groups administration panel" i go there http://buddy17.dev/wp-admin/admin.php?page=bp-groups and i get a WordPress error (not sufficient rights to display the page)

i suggest to disable the link if the group component is not activated.

Change History (4)

#1 @boonebgorges
9 years ago

  • Milestone changed from Awaiting Review to 1.7

i suggest to disable the 2 links in that case as once on the Components panel, a message shows and invites us to update permalinks.

Permalink settings should (?) be changed automatically during installation. I'll have to check on that.

i suggest to disable the link if the group component is not activated.

Great catch.

#2 @boonebgorges
9 years ago

(In [6763]) Only link 'Groups administration panel' on Welcome screen if Groups is active

See #4800

Props imath

#3 @boonebgorges
9 years ago

I did some investigation and it looks like we *don't* turn on pretty permalinks during activation. Let's leave it this way for now - changing permalink settings is problematic (we don't know that we'll have write-access to .htaccess, for example). I'll check permalink settings before creating the links.

#4 @boonebgorges
9 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6768]) On new install screen, don't link Members and Activity directories if pretty permalinks aren't enabled

Fixes #4800

Note: See TracTickets for help on using tickets.