Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 8 years ago

#4514 closed defect (bug) (no action required)

bp_send_message_button function within the members loop

Reported by: thirstcard Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.6.1
Component: Core Keywords:
Cc:

Description

Step 1. Call bp_send_message_button() from within the members loop
Step 2. Click on the 'send message' button that is displayed for a particular member

Expected behaviour is to be taken to the 'compose message' page with the username field being pre-populated with the particular member's username.

Actual behaviour - taken to the 'compose message' page but the username field isn't pre-populated.

Change History (2)

#1 @DJPaul
8 years ago

  • Keywords reporter-feedback added

Was this in a custom theme template, or is it occuring somewhere inside BuddyPress' default theme? If it's a custom template, are you able to share the relevant markup so we can recreate the issue easily? Thanks.

#2 @boonebgorges
8 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

By the looks of things, bp_send_message_button() is not intended to work in the user directory. It calls bp_get_send_private_message_link(), which creates the link using bp_core_get_username( bp_displayed_user_id() ). In the case of member directories, there *is* no bp_displayed_user_id(). If you want to have a button in the directory, you'll need to build your own (or filter 'bp_get_send_private_mesage_link' and provide your own link)

Note: See TracTickets for help on using tickets.