Skip to:

Opened 4 years ago

Closed 2 weeks ago

#4505 closed defect (bug) (wontfix)

With BuddyPress 1.6.1, Wordpress's Register link redirects to BuddyPress

Reported by: dharmen99 Owned by: dharmen99
Milestone: Priority: normal
Severity: normal Version: 1.6.1
Component: Core Keywords: reporter-feedback


After updating to BuddyPress 1.6.1 (BP is on a secondary site on a sub directory 2 site network), the WordPresss 'Register' link redirects to BuddyPress and not the the WP registration page. I updated BP from 1.5.6. WordPress is 3.4.1.

To try to find out what was happening, I installed two test sites on my server, both with virgin instals of WordPress and BP. I did not instal any additional plugins so the sites are running standard basic instals. Both sites are running WP 3.4.1. On one site I installed BP 1.6.1 and the other BP 1.5.6. (Permalinks are set to Numeric). The result you can see from these links:

The first site (test) has BP 1.6.1, the second (test2) has BP 1.5.6 The sub directory were BP is active is called 'now' in both cases. If you follow the links above and then click 'Register' (under Meta) you will find that with the first site (test), the 'Register' link will redirect to whereas the second site (test2) will behave correctly and redirect to

It is possible that this is a bug with WordPress but as it only manifested when I installed BP 1.6.1 I thought you should know about it. I believe the same thing happens with BP 1.5.7

Change History (7)

#1 @dharmen99
4 years ago

  • Keywords reporter-feedback removed

#2 @dharmen99
4 years ago

On another installation I have updated to WP 3.4.2 and the problem still persists. If I deactivate BuddPress the problem goes away and the register link works correctly.

#3 @boonebgorges
4 years ago

It sounds like this is mostly intended behavior. By design, BuddyPress redirects all requests to wp-signup.php to its own registration pages, across the network.

However, it does seem strange that you're getting redirected to the *blog* creation screen. I'll have a closer look.

#4 @dharmen99
4 years ago

Have now updated the two test sites to WP 3.4.2 No change in what happens when clicking the register link.

#5 @DJPaul
4 years ago

  • Keywords reporter-feedback added; needs-testing 2nd-opinion removed
  • Milestone changed from Awaiting Review to Future Release

Moving this to future release for review, but could do with anyone able to test this and see if the issue can be re-created.

#6 @r-a-y
5 weeks ago

  • Milestone changed from Future Release to Awaiting Review

#7 @DJPaul
2 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Closing this because we never tested it, and we've not heard or seen this issue since. We'll re-open if it reoccurs in the future.

Note: See TracTickets for help on using tickets.