Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 7 years ago

#4424 closed defect (bug) (no action required)

Log out error bug

Reported by: shawn38 Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.6
Component: Core Keywords:
Cc:

Description

After I log in on my home page in which mine is the activity as I had set up in the dashboard/settings/reading Front Page displays. The bug is this: I can log in and out on every buddypress page except if you go to “Edit My Profile” and then try to log out it redirects to “Page not found.” I am using no plugins, just wordpress 3.4.1 and buddypress 1.6 on localhost for testing. I have multiple installations of this on my localhost and this bug is repeatable.

Change History (2)

#1 @DJPaul
7 years ago

  • Keywords needs-patch removed

It's not a bug. "Edit My Profile" is a privileged page, you have to be logged in and be that user, or a site admin. Everyone else, including logged out users, can't access the "Edit My Profile" page, so BuddyPress throws a 404 (page not found) status.

We could investigate making the default theme's log out button a bit smarter about where it redirects you to after a log out. If it's a protected page, we could return them to the root of the site perhaps. Needs further input from other developers.

#2 @DJPaul
7 years ago

  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Not a bug; this works as explained in my previous comment. Closing ticket.

Note: See TracTickets for help on using tickets.