Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 4 years ago

#4343 closed defect (bug) (worksforme)

BuddyPress Activity Component repeat entry after replying on favorites page

Reported by: thirstcard Owned by:
Milestone: Priority: normal
Severity: minor Version: 1.5.6
Component: Activity Keywords:
Cc:

Description

  1. Favorite an entry in the activity feed
  2. Go to page http://example.com/members/admin/activity/favorites/
  3. While on this page, reply to the entry you just favorited
  4. You have the original entry repeat itself above your reply (see http://static.inky.ws/image/2370/image.jpg)

Note this only affects the ajax/js entry that is automatically inserted without a page load. After page load the repeat entry is removed. Also note that the repeated entry "a message" has a timestamp of 29 seconds ago which happened before the original entry (19 seconds ago).

Change History (7)

#1 @boonebgorges
9 years ago

  • Keywords reporter-feedback added

Hm, I can't reproduce this (BP r6173, WP 3.4.1). Could you please provide details about your installation? BP+WP versions, theme, plugins. Thanks!

#2 @thirstcard
9 years ago

Sure Boone no problem,

Web Browser: Chrome/FF/Internet Explorer - all versions.
Server OS: Linux
Web Server: Apache
PHP version: 5.2.16
WordPress Version: 3.4.1
Plugins:
BuddyPress (version: 1.5.6)
BP Disable Activation (version: 0.4)
BP Profile Search (version: 3.1)
BuddyPress Follow (version: 1.1.1)

I tried with both a custom theme and the default theme (bp-default) and got the same result.

#3 @boonebgorges
9 years ago

Can you try disabling the other plugins?

#4 @thirstcard
9 years ago

Hi Boone

I disabled every plugin and still had the same result.

The page where the favorited-post is created is important. The following may help you reproduce...

If you create a post at the following page, favorite it, and then carry out the steps I outlined above, then the problem occurs:

http://example.com/members/admin/activity/

However, the problem doesn't occur if you create a post and favorite it from page:

http://example.com/activity/

Last edited 9 years ago by thirstcard (previous) (diff)

#5 @boonebgorges
9 years ago

  • Milestone changed from Awaiting Review to Future Release
  • Severity changed from normal to minor

Thanks for the additional details. I've confirmed the bug. Let's look at it for BP 1.7.

#6 @boonebgorges
9 years ago

  • Keywords reporter-feedback removed

#7 @slaFFik
4 years ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Can't replicate on a current WordPress and BuddyPress installs with BP Default and any default WordPress themes. Closing this issues, seems it was fixed since then.

Note: See TracTickets for help on using tickets.