Skip to:
Content

#4344 closed enhancement (fixed)

"Notify group members of changes via email" UX is lousy

Reported by: frank13 Owned by:
Milestone: 1.8 Priority: normal
Severity: minor Version:
Component: Groups Keywords:
Cc: frank13, rachel@…, karmatosed@…

Description

I want to turn on notification of "Notify group members of changes via email" in my BuddyPress Groups. I click the Yes radio button and then click Save Changes but the setting keeps reverting back to No

How can I set my groups so that all members get notified of new activity?

Change History (9)

comment:1 boonebgorges22 months ago

  • Component changed from Core to Groups
  • Milestone changed from Awaiting Review to Future Release
  • Severity changed from major to minor
  • Summary changed from "Notify group members of changes via email" radio button settings sticks on No and cannot be set to Yes to "Notify group members of changes via email" UX is lousy
  • Type changed from defect (bug) to enhancement

The radio button is working as designed, but it's a poor user interface.

For one thing, the button does not do what you are expecting it to do. It's not designed to notify all users of group activity. Instead, checking 'Yes' will only notify group members *that you have changed the group's name or description*. To allow users to receive email notifications of all group activity, see this plugin: https://wordpress.org/extend/plugins/buddypress-group-email-subscription/ Our help text should be better here, to make the point clearer.

For another thing, the radio button is a poor choice of input element in this case. RBs are generally used for persistent settings. The "Notify" option is a one-time thing: I'm changing the name or description of the group, and I want users to know about it. It should probably be a checkbox instead.

I suggest something like:

[ ] Notify group members that the group's details have been changed

comment:2 frank1322 months ago

Excellent, thanks (again) @booneborges !!

Installed and test it -- works really slick!

Last edited 22 months ago by frank13 (previous) (diff)

comment:3 rachelbaker21 months ago

  • Cc rachel@… added

comment:4 hnla14 months ago

  • Version changed from 1.5.6 to 1.7

Prompted by my duplicate ticket #4833.

In other words this is a one time action that pertains to the current save about to be actioned.

The lousy (marginally so though) UX in all this is the descriptive text, this had me wasting time looking at this on behalf of a forum post, I should perhaps have known that this was the intention of the input, in fact in many senses I ought to have known but clearly that passed me by, why?

Words! it's simply a case of writing stuff that is meaningful "notify all group members of these changes" or something along those lines that clarifies the action is for this change only

@boone Yes this is a wholly incorrect use of radio buttons, why was it ever written using them, this is a checkbox, it requires no settings check as it's not intended as persistent it's simply a check for 'true' or '1' at time of submission after which returns to unchecked/empty.

Strikes me this is a simple change with little consequence accept better UX and use of correct form controls.

comment:5 boonebgorges14 months ago

  • Milestone changed from Future Release to 1.8
  • Version 1.7 deleted

"Version" is the first version where the issue cropped up. Please don't bump it up.

You're right that this is a straightforward change. Putting in 1.8.

comment:6 hnla14 months ago

"Version" is the first version where the issue cropped up. Please don't bump it up.

Oops my bad, didn't realise that, not doing a lot right at the moment, time to focus on work :)

Last edited 14 months ago by hnla (previous) (diff)

comment:7 karmatosed13 months ago

  • Cc karmatosed@… added
  • Keywords needs-ui added

comment:8 boonebgorges12 months ago

In 6955:

Improved UX for "Notify group members of changes" toggle

The "Notify group members...." toggle on the 'edit-details' screen of the group
admin is intended to allow the group administrator to send an email to the
group members when the group's name or description has changed. However, the
legacy UX - a radio button (suggesting a persistent setting), and the text
(which suggests persistent notifications) - have historically been misleading.
By changing the radio button to a checkbox, and making a slight modification to
the wording of the text, the purpose of the checkbox should be much clearer.

See #4344

comment:9 boonebgorges12 months ago

  • Keywords needs-ui removed
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.